cancel
Showing results for 
Search instead for 
Did you mean: 

Don't bother with CE2.0.0 with Sample Data

Don't bother with CE2.0.0 with Sample Data

As the title says, don't waste your life trying to install the 2.0.0 with sample data, it just does NOT work.

 

I have just wasted a few hours of my life trying to install it and every time it fails, did they even bother to test this before making it available to download?

9 REPLIES

Re: Don't bother with CE2.0.0 with Sample Data

We are aware of this issue, fix will be available in subsequent version. If you are eager to try it, fix is in the git version, in the develop branch.  See this link how to use the git version: http://devdocs.magento.com/guides/v2.0/install-gde/prereq/dev_install.html. Please note this version is not meant for production.

Re: Don't bother with CE2.0.0 with Sample Data

I think Magento 2.0 is a giant failure altogether.  Working with nearly every self hosted eCommerce platform over the years, I have never had the adversity and difficulty as I have had with Magento 2.0.  Just trying to get it installed and setup properly has been a nightmare

Re: Don't bother with CE2.0.0 with Sample Data

Thanks for trying to help but this release with the sample data should be pulled, as I and probably others have wasted countless hours with a non-working download. The reason for this thread is primarily to warn others not to waste time downloading it.

 

Seeing as how I seem to be struggling to get composer to work in any reliable way and how it has broken my installation I don't favour trying that method. I will just have to wait for the next release to try with the sample data.

 

To reiterate, WARNING DO NOT DOWNLOAD Magento-CE-2.0.0+Samples-2015-11-17-06-24-03

Only the Magento-CE-2.0.0-2015-11-17-05-53-58 download without the sample data works, don't be tempted to try the post-install method to install the sample data as that will fail as well unless you can get the git development branch to work.

Re: Don't bother with CE2.0.0 with Sample Data

Darren,

 

Were you getting errors like this in PuTTy when trying to install the sample data?:

 

  Problem 1
    - The requested package magento/module-review-sample-data could not be found in any version, there may be a typo in the package name.

 

I got about 200 lines saying 'could not be found'.  I am just trying to figure out if that is on the Magento end or if I mistyped the command somehow (new to SSH)


My command in SSH was: [~/public_html]# php bin/magento sampledata:deploy

Re: Don't bother with CE2.0.0 with Sample Data

"Giant failure altogether ...I have never had the adversity and difficulty as I have had with Magento 2.0."

 

Which install methods have you tried? There are several.

-----
@benmarks, Developer & Community Evangelist at Magento

Re: Don't bother with CE2.0.0 with Sample Data

Did you try setting the max_execution_time as suggested?

Re: Don't bother with CE2.0.0 with Sample Data

Yes, I'm puzzled why you are still asking as it has already been acknowledged that there are problems with the sample data that have been fixed in the development branch and therefore should be included in the next release?

Re: Don't bother with CE2.0.0 with Sample Data

The fix in the develop branch is only for those deploying via git or composer create-project. It should be working fine for the zip file downloaded from magento.com

Re: Don't bother with CE2.0.0 with Sample Data

OK, I think the heart of the problem is with segmentation faults on PHP 7.