cancel
Showing results for 
Search instead for 
Did you mean: 

Error after migration with migrate:settings

Highlighted

Error after migration with migrate:settings

Hi all,

 

Am struggeling that after a successful settings migration I'm getting the following error on every URL that I try to reach.

 

{"0":"Expecting a string, got NULL","1":"<pre>#1 Zend\\Uri\\Uri->parse() called at [vendor\/magento\/module-backend\/App\/Area\/FrontNameResolver.php:140]\n#2 Magento\\Backend\\App\\Area\\FrontNameResolver->getHostWithPort() called at [vendor\/magento\/module-backend\/App\/Area\/FrontNameResolver.php:129]\n#3 Magento\\Backend\\App\\Area\\FrontNameResolver->isHostBackend() called at [vendor\/magento\/module-backend\/App\/Area\/FrontNameResolver.php:106]\n#4 Magento\\Backend\\App\\Area\\FrontNameResolver->getFrontName() called at [vendor\/magento\/framework\/App\/AreaList.php:73]\n#5 Magento\\Framework\\App\\AreaList->getCodeByFrontName() called at [vendor\/magento\/framework\/App\/Http.php:132]\n#6 Magento\\Framework\\App\\Http->launch() called at [generated\/code\/Magento\/Framework\/App\/Http\/Interceptor.php:24]\n#7 Magento\\Framework\\App\\Http\\Interceptor->launch() called at [vendor\/magento\/framework\/App\/Bootstrap.php:261]\n#8 Magento\\Framework\\App\\Bootstrap->run() called at [pub\/index.php:40]\n<\/pre>","url":"\/\/data\/web\/magento2\/pub\/errors\/default\/images\/favicon.ico","script_name":"\/index.php"}

 

Tried to find it, but am not able to pinpoint the issue. Support is most welcome.

4 REPLIES 4
Highlighted

Re: Error after migration with migrate:settings

You should find path = web/unsecure/base_url in the table core_config_data, then check whether the value is set.

Highlighted

Re: Error after migration with migrate:settings

The issue is due to migrated settings. Please check core_config_data table and set admin/url/use_custom to 0. Then refresh the cache.

Highlighted

Re: Error after migration with migrate:settings

edit base url  in core_config_data

Highlighted

Re: Error after migration with migrate:settings

You should find  web/unsecure/base_url in the table core_config_data, then set value to <your domain>.