cancel
Showing results for 
Search instead for 
Did you mean: 

Error saving new product after install Magento 2.3.5-p1

Highlighted

Error saving new product after install Magento 2.3.5-p1

Hi guys i'm truning crazy to solve that error, not info found, The Error comes when i try to create a new product. 

 

Fatal error: Uncaught Error: Cannot instantiate interface Magento\Framework\MessageQueue\ConfigInterface in /var/www/vhosts/website.es/httpdocs/magento2/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:50 Stack trace: #0 /var/www/vhosts/website.es/httpdocs/magento2/vendor/magento/framework/ObjectManager/ObjectManager.php(70): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\\Framewo...') #1 /var/www/vhosts/website.es/httpdocs/magento2/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(167): Magento\Framework\ObjectManager\ObjectManager->get('Magento\\Framewo...') #2 /var/www/vhosts/website.es/httpdocs/magento2/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(273): Magento\Framework\ObjectManager\Factory\AbstractFactory->resolveArgument(Array, 'Magento\\Framewo...', NULL, 'queueConfig', 'Magento\\Framewo...') #3 /var/www/vhosts/website.es/httpdocs/magento2/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(236): Magento\Framewor in /var/www/vhosts/website.es/httpdocs/magento2/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php on line 50

 

All help will be apreciated, really tried all, but the error persist and it start to turn me crazy Smiley SadSmiley SadSmiley SadSmiley Sad

1 REPLY 1
Highlighted

Re: Error saving new product after install Magento 2.3.5-p1

Ok  i really don't solved the exact issue, if someone have idea of the exact problem can be useful for others, anyway:

 

Finally i solved it, reinstalling again, this time from SSH: and composer- to import the files and modules, more work to config properly all thinks like the magento-repo,   composer, files permissions,  and all the depencies that it goes asking from composer-update, but at least this time is working correctly and i can create products.

 

And in fact from this way, i have the server corractly configurated for SSH, that will make me easier in future to intall modules, make updartes, and upgrade patches.