cancel
Showing results for 
Search instead for 
Did you mean: 

File Permission Check 4 file permission not met.

File Permission Check 4 file permission not met.

Try to install Magento 2.0.2, but without success. I keep getting an error message about file permissions. I work with FTP client FileZilla and DirectAdmin. I'm new with Magento. Maybe someone can help me?

I have changed the permissions on files Chmod 777


Please see below

 

 

File Permission Check

4 file permission not met. Hide detail

The best way to resolve this is to allow write permissions for the following Magento directories and their sub-directories. The exact fix depends on your server, your host, and other system variables.
Our File Permission Help can get you started.

If you need more help, please call your hosting provider.

"/home/natuurkr/domains/natuurkruiden.nl/public_html/app/etc" writable directory permission.
"/home/natuurkr/domains/natuurkruiden.nl/public_html/var" writable directory permission.
"/home/natuurkr/domains/natuurkruiden.nl/public_html/pub/media" writable directory permission.
"/home/natuurkr/domains/natuurkruiden.nl/public_html/pub/static" writable directory permission.

 

Set==

Directory app 120k 777
etc 80.0k 777

 

Directory var 128k 777


Directory pub 200k 777
Directory media 40.0k 777
Directory static 8.00k 777

 

10 REPLIES

Re: File Permission Check 4 file permission not met.

Re: File Permission Check 4 file permission not met.

I'm also having this problem. (Using a CentOS server)

 

I've been to the permissions page, I ran the suggested scripts and still the same error.

So am I missing something? permissions 777 should grant everyone regardless of who they are or what group they are. I also changed all sub files and sub directories too, still fails.

 

Could this be a plugin configuration error? I don't want to change the entire www root folder to 777, but this is a dev environment and will.

Re: File Permission Check 4 file permission not met.

Ok, so I changed all the file permissions and folder permissions to have full access. I read on another post that there is some php to change permissions of folders, so I'm going to try to look there next.

 

If a Magento dev sees this the install documentation is lacking, with a freshly installed CentOS 7 64bit VM there were several libraries that needed to be installed, which are never mentioned in the install guide.

Re: File Permission Check 4 file permission not met.

Followed the instructions and still getting this when it runs the system check. Can you please advise if there is another way around this. I am installing this on my own server on Ubuntu 16.04 LTS with LAMP stack installed 

File Permission Check

4 file permission not met. 

The best way to resolve this is to allow write permissions for files in the following Magento directories and subdirectories. The exact fix depends on your server, your host, and other system variables.
For help, see our file [permissions help


  • "/var/www/html/app/etc" - Not writable, change the permissions.
  • "/var/www/html/var" - Not writable, change the permissions.
  • "/var/www/html/pub/media" - Not writable, change the permissions.
  • "/var/www/html/pub/static" - Not writable, change the permissions. 

Re: File Permission Check 4 file permission not met.

I managed to do it. Thanks Issue is resolved. 

Re: File Permission Check 4 file permission not met.

I'm having the same issue. How did you do it? Can you share the solution?

 

Thanks

Re: File Permission Check 4 file permission not met.

I had the same issue installing Magento 2.1.8 and, changing the owner of those 4 folders/directories to the user apache runs, made it pass the File Permissions Check right away.

This is in CentOS, "sudo" makes it run as root, and apache is my httpd user and group, so adapt as needed:
sudo chown -R apache:apache /path/to/magento/var/
sudo chown -R apache:apache /path/to/magento/pub/media/
sudo chown -R apache:apache /path/to/magento/pub/static/
sudo chown -R apache:apache /path/to/magento/app/etc/


I've been trying everything I found, from devdocs permissions guide to chmod 777 (775, 755, 700, ...), selinux disable, nothing worked until I tried the above. Changing the owner of those folders to the user apache runs.

Re: File Permission Check 4 file permission not met.

Further investigating this error to avoid it and correctly install in productions, it seems I found the problem. This is in CentOS, and on a two user system (like in the guide docs: one is the magento files user(magento_user), the other is the webserver (apache)). So, feel free to adjust to your system:

The problem seems to be the ACL: Access Control Lists. Read more to understand it:

https://www.centos.org/docs/5/html/5.2/Deployment_Guide/s1-acls-setting.html

https://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-acls-retrieving.html

https://superuser.com/questions/191903/how-do-i-remove-any-selinux-context-or-acl

If a file or directory already has an ACL, and the setfacl command is used, the additional rules are added to the existing ACL or the existing rule is modified. For example, to give read and write permissions to a user andrius: ($ sudo setfacl -m u:apache:rw /var/www/html/)

Following those readings I did this in the webserver folder containing the Magento2 folder:

$ sudo find . -exec sudo setfattr -h -x security.selinux {} \;

And them this to remove ACL from the web server docs root:

$ sudo setfacl -bRP --test /var/www/html/
$ sudo setfacl -bR /var/www/html/


Finally, (as magento files user) to make sure the permissions are set as recommended:
$ su magento_user

$ cd /var/www/html/Magento2
$ find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} \;

$ find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} \;
$ chown -R :apache .

$ chmod u+x bin/magento

$ sudo service httpd restart

If you don't have the setfattr or setfacl command, install it: 

https://globedrill.com/setfattr-command-not-found-how-to-install-setfattr-command-on-linux-server/


After doing this, Magento2 installs just fine, and I no long have permission problems.
Hope this can help you solve that annoying error and improve your work.

Cheers

Re: File Permission Check 4 file permission not met.

Had the same issue. For ubuntu server this was the fix for me.

 

sudo chown -R www-data:www-data /path/to/magento/var/
sudo chown -R www-data:www-data /path/to/magento/pub/media/
sudo chown -Rwww-data:www-data /path/to/magento/pub/static/
sudo chown -Rwww-data:www-data /path/to/magento/app/etc/