cancel
Showing results for 
Search instead for 
Did you mean: 

How to Keep From Getting "System Message - Indexers Are Invalid"

SOLVED

How to Keep From Getting "System Message - Indexers Are Invalid"

I spent all day yesterday attempting to make sure Magento 2.0.2 cron is setup correctly and working, that I fully disabled cache and that my indexers were working. Thought I was done.

 

Just logged in this morning to this frustrating message --> https://drive.google.com/open?id=0Bytqhoir_Tt5NWkxb3VBanZRbmM

 

What am I doing wrong? How can I get Magento 2.0 to work? How can I get the indexers to index?

2 REPLIES

Re: How to Keep From Getting "System Message - Indexers Are Invalid"

Re: How to Keep From Getting "System Message - Indexers Are Invalid"

Hello,

 

If you do it for your client and don't want to confuse him with such messages. (There will be much more RED frightening alerts like "Magento is not up to date", "Apply security patch")

 

Maybe it is better to disable system notification instead of disabling magento cache and forcing each minute reindexing with cron job.

 

 

Magento admin panel -> Stores -> Configuration -> Advanced -> Advanced

 

Set Magento_AdminNotification to "Disable" and click the "Save Config" button.

 

 

 

 

Stanislav