cancel
Showing results for 
Search instead for 
Did you mean: 

Install Magento 2.4.1 on win10 : Get favicon failed

Install Magento 2.4.1 on win10 : Get favicon failed

Hi There,

 

I have install magento 2.4.1 on win10 using composer with xampp. It seems good until I install sampledata

 

php bin/magento sampledata:deploy

then I did the following

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy -f

php bin/magento c:c

 

After I open the localhost webiste:

 

There is a error in the console so the page cannot load

 get http://localhost/pub/static/version1627600371/frontend/_view/en_AU/Magento_Theme/favicon.ico  [HTTP/1.1 404 Not Found 1642ms]

 

But I can find this file in the directory

C:\xampp-webstore\htdocs\magento2\pub\static\frontend\Magento\luma\en_AU\Magento_Theme\favicon.ico

 

What is the problem here ? Thanks for any advice and suggestion

2 REPLIES 2

Re: Install Magento 2.4.1 on win10 : Get favicon failed

By the way in the compile process there is a error:

 

Interception cache generation... 6/9 [==================>---------]  66% 5 mins 372.0 MiBErrors during compilation:
        Magento\Framework\Setup\Option\AbstractConfigOption
                Incompatible argument type: Required type: int. Actual type: string; File:
C:/xampp-webstore/htdocs/magento/vendor/magento/framework/Setup/Option/AbstractConfigOption.php

Total Errors Count: 1

I search it and use this to solve the problem

composer require symfony/console=4.4.26

I don't know if there is issue here

Re: Install Magento 2.4.1 on win10 : Get favicon failed

That is weird. After uninstall the sample data the homepage can load normally and I check the favicon. The path for that is 

http://localhost/pub/static/frontend/Magento/luma/en_AU/Magento_Theme/favicon.ico
 
In the sampledata situation, there is a additional directory  /_view/