cancel
Showing results for 
Search instead for 
Did you mean: 

Installation on mac os

Installation on mac os

Hello,
I'm trying to install for the first time Magento 2 on Mac os with Apache / 2.2.26 and PHP 5.5.30 but I get this error:
 
  PHP Settings Check
Your current setting of xdebug.max_nesting_level = 100. Magento 2 requires it to be in September to 200 or blackberries. Edit your config, restart the web server, and try again.
 
In php.ini I tried to add "; xdebug.max_nesting_level = 200" under the following lines but the result does not change.
 
[xdebug]
; xdebug.idekey = "macgdbp"
; xdebug.remote_enable = 1
 
 
It'd appreciate a little help
Thank you

4 REPLIES

Re: Installation on mac os

Semicolon is a comment symbol for php.ini files, so the lines which started with semicolon arre not regarded.

You should remove the semicolon for the xdebug.max_nesting_level option.

My xdebug.ini settings: https://mage2.pro/t/304

Re: Installation on mac os

Thanks for the reply

I tried with

[xdebug]

; xdebug.idekey = "macgdbp"

; xdebug.remote_enable = 1

xdebug.max_nesting_level = 400

 

I restart apache too but it is the same

 

 

Re: Installation on mac os

I solved put the following code in top of setup/index.php

ini_set('xdebug.max_nesting_level', 200)

 but the installation process stops at 90% and my settings in the php.ini file are:

 

max_execution_time = 18000

max_input_time = 1800

memory_limit = 1024M

Re: Installation on mac os

Perhaps this php.ini file is not loaded. Please check the value via <?phpinfo()?>