cancel
Showing results for 
Search instead for 
Did you mean: 

Installing CE 2.1.2 – Web Setup Never Completes

Installing CE 2.1.2 – Web Setup Never Completes

Hello, Magento Community!

 

My name is Denis and I've been using Magento 2 since January, 2016.

 

I've reinstalled the system already for like dozens of times and still can't make it work fast and without occasional issues.

 

Now, I'm experiencing a trouble to simply fresh install 2.1.2 (complete the installation process) on a BlueHost VPS hosting.

 

The progress bar stops at 73% – while the setup wizard is installing the Magento_Weee module.
And the browser throws a 401 Unauthorized Access error.

 

My VPS plan is:

 

  • 2 CPU Cores
  • 30GB SAN
  • 2GB RAM
  • 1TB Monthly Bandwidth

 

System info:

 

  • Apache 2.4
  • CentOS 6.8
  • PHP 5.6.28 w/ all of the modules Magento 2 requires installed
  • MySQL 5.6.34
  • OPcache 7.0.4

 

The server runs as a 'nobody' user. PHP is served by DSO handler.

I'm able to provide any additional info anytime.

 

I carefully read and follow all the steps described in the Magento 2 Installation Guide.

However, still can't get the system installed w/o an error.

 

Could you, guys, please, kindly help me with that?

 

Any help or advice will be greatly appreciated!

 

Thanks!

 

Denis

3 REPLIES

Re: Installing CE 2.1.2 – Web Setup Never Completes

You are probably hitting PHP memory limits, you ideally should Increase the PHP memory limit to at least 768MB in your php.ini configuration.

Re: Installing CE 2.1.2 – Web Setup Never Completes

Hello, Darren!

 

Thank you so much for your reply!

 

The PHP Memory Limit was set to 768MB, now it's 2G.

The Web Setup Wizard still can't complete the installation process.

 

Thanks again.

 

Denis

Re: Installing CE 2.1.2 – Web Setup Never Completes

Hi Denis,

 

It is for sure a memory related issue. Please make sure you are making updates to the correct php.ini as there can be multiple configuration files placed at different locations. Setting the following value usual works:

Change max_execution_time = 18000
Change memory_limit = 768M

 

Also, once the process gets stuck, delete the database and create a fresh one (may be with the same name). Continue with the installation and hopefully it would work.