cancel
Showing results for 
Search instead for 
Did you mean: 

Issue With Installer Wizard on a VM

SOLVED

Issue With Installer Wizard on a VM

Hi,

I'm trying to build a Magento local environment for updating production to the latest version. I have been using Vagrant and Ubuntu 14.04 with virtualbox.

I went through the LAMP stack installation easily enough, and didn't encounter any issues. However, after installing with composer and navigating to the directory it installed in for setup (in this case, it was "localhost/magento2/setup") and encountered the following:

{$e->getMessage()}

HTML; exit(1); } // For Setup Wizard we are using our customized error handler $handler = new \Magento\Framework\App\ErrorHandler(); set_error_handler([$handler, 'handler']); $configuration = require __DIR__ . '/config/application.config.php'; $bootstrap = new Application(); $application = $bootstrap->bootstrap($configuration); $application->run();

This lead me to believe my php installation was unsuccessful, but my phpinfo.php file loads fine, and the output seems correct. I also double and triple checked the php modules, but didn't see anything that was missing from the php section in the documentation.

I'm running PHP 7.0.28, Apache 2.4.7, and mysql 5.6.39, all on Ubuntu Server 14.04.

Any help or insight is appreciated, as I searched similar errors on the forum but didn't find a solution that seemed to work (although I haven't tried reinstalling everything).

 

Tags (2)
2 REPLIES

Re: Issue With Installer Wizard on a VM

I fixed this today, I uninstalled and reinstalled php, apache2, and mysql and it worked like a charm!

Re: Issue With Installer Wizard on a VM

Glad to hear that! Marking your response as solution. Smiley Happy

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips