cancel
Showing results for 
Search instead for 
Did you mean: 

MAMP on Mac Not Starting Up

MAMP on Mac Not Starting Up

I've got MAMP, Elasticsearch, and Magento 2.4.3-p1 installed and running.

 

My problem is that I've got it all done, it's not coming up in the browser.

II've followed all instructions from this site: https://therealprogrammer.com/how-to-install-in-magento-2-in-macbook/ 

It didn't create an index.php in the MAMP/htdocs/magento2 subdirectories, so I copied one from my live system (on Nexcess, so it's possible I'm really missing something), but clearly, it isn't coming up. Here's the index.php:

 

<?php
/**
 * Public alias for the application entry point
 *
 * Copyright © Magento, Inc. All rights reserved.
 * See COPYING.txt for license details.
 */

use Magento\Framework\App\Bootstrap;

try {
    require __DIR__ . '/../app/bootstrap.php';
} catch (\Exception $e) {
    echo <<<HTML
<div style="font:12px/1.35em arial, helvetica, sans-serif;">
    <div style="margin:0 0 25px 0; border-bottom:1px solid #ccc;">
        <h3 style="margin:0;font-size:1.7em;font-weight:normal;text-transform:none;text-align:left;color:#2f2f2f;">
        Autoload error</h3>
    </div>
    <p>{$e->getMessage()}</p>
</div>
HTML;
    exit(1);
}

$bootstrap = Bootstrap::create(BP, $_SERVER);
/** @var \Magento\Framework\App\Http $app */
$app = $bootstrap->createApplication(\Magento\Framework\App\Http::class);
$bootstrap->run($app);

I'm trying several version of these two urls, front-end, and back-end, but no-go.

http://localhost/MAMP/htdocs/magento2/index.php 

and http://localhost/htdocs/magento2/admin 

 

Any suggestions to bring up my site?

 

Thanks.

 

2 REPLIES 2

Re: MAMP on Mac Not Starting Up

Here is the possible solution for your problem:

Solution 1:

<VirtualHost *:80>
ServerName magento.com
DocumentRoot /Applications/MAMP/htdocs/magentotwo
<Directory "/Applications/MAMP/htdocs/magentotwo">
AllowOverride All
Allow from all
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
</IfModule>
</Directory>
</VirtualHost>

 

Solution 2: Check Search Engine Optimization option enabled in admin or not. To check it you can check this step Admin->Store->Configuration->General->Web->Search Engine Optimization->YES

If issue solved, Click Kudos & Accept as Solution.
LitCommerce - The Most Simple & Affordable Multi-channel Selling Tool

Re: MAMP on Mac Not Starting Up


@LitCommerce Expert wrote:

Here is the possible solution for your problem:

Solution 1:

<VirtualHost *:80>
ServerName magento.com
DocumentRoot /Applications/MAMP/htdocs/magentotwo
<Directory "/Applications/MAMP/htdocs/magentotwo">
AllowOverride All
Allow from all
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
</IfModule>
</Directory>
</VirtualHost>

 

Solution 2: Check Search Engine Optimization option enabled in admin or not. To check it you can check this step Admin->Store->Configuration->General->Web->Search Engine Optimization->YES


Okay, that makes sense. Thanks for the answers.