cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.0 fresh install IIS not loading java or css

Magento 2.0 fresh install IIS not loading java or css

Noticed Magento 2.0 came out so I wanted to setup check it out.

 

 +===================================+
 | Server Info |
 +===================================+

 | Windows Server 2012 Standard

 | Internet Information Services (IIS)

 | php 5.6.7 - using php manager

 

 +===================================+
 | Test Site Subdomains |
 +===================================+

 | http://euniformstore.vigilant1.com/

 | Admin URL

 

 +===================================+
 |
PHP Tweaks |
 +===================================+

 | max_execution_time = 1300

 | memory_limit = 768

 

note - permissions are setup correctly

note - 404 page not found resolved after adding rewrites below to web.config file

side not - able to install magento 1.9.2 no problem

 

 +===================================+
 |
Rewrites added to web.config |
 +===================================+

 

    <rewrite> 
      <rules> 
        <rule name="Remove index.php rule" stopProcessing="true"> 
          <match url=".*" ignoreCase="false" /> 
          <conditions> 
            <add input="{URL}" pattern="^/(media|skin|js)/" ignoreCase="false" negate="true" /> 
            <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" /> 
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" /> 
          </conditions> 
          <action type="Rewrite" url="index.php" /> 
        </rule> 
      </rules> 
    </rewrite>

Not sure what to do from here. Ive tried everything I can think of any help would be appreciated.

Can pay for help to the solution as well 480-203-6421.

1 REPLY

Re: Magento 2.0 fresh install IIS not loading java or css

If you open a command prompt aka CLI you can get.
php is not recognized as an intern command (using windows)

 

PHP is not included in your PATH. Right click your My Computer, then Properties, Advanced System Settings, Environment Variables and then find PATH variable, add your PHP installation dir there. Close your previously launched CMDs, re-launch it, it should work now.

https://www.youtube.com/watch?v=ruqgCRq-pfg

 

php bin/magento setup:static-content:deploy

 

php bin/magento setup:static-content:deploy en_GB