cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.2.2 installation

SOLVED

Magento 2.2.2 installation

Hello,

I have been having problems installing Magento 2.2.2 on my xampp local server. It is stuck at 0% and it remains like that for hours with no progress.

 

I have done the followings adjustments on php.ini still the same issue

memory_limit = 1024M

max_execution_time = 18000
max_input_time = 1800

Urgent help needed please. 

Thanks

14 REPLIES

Re: Magento 2.2.2 installation

Hi @samir_areh,


Can you check your webserver error log?

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Magento 2.2.2 installation

Hello Damian

How do I go about that. Can you put me through 

Re: Magento 2.2.2 installation

You need to refer below links for check error log of your server,

https://stackoverflow.com/questions/5127838/where-does-php-store-the-error-log-php5-apache-fastcgi-c...

 

For cpanel related stuff,

https://mediatemple.net/community/products/dv/204403804/where-are-the-access_log-and-error_log-files...

If Issue Solved, Click Kudos/Accept As solutions.

Re: Magento 2.2.2 installation

Thank Rakesh for your reply,

I am installing Magento on my local server which xampp. and it freezes during installation. 

Please I need urgent help.

Re: Magento 2.2.2 installation

Check your PHP version of WAMP server.  Its might be incompatible technology stack of wamp server.

 

Magento 2.2 have specific technology stack which requires to install Magento 2.2 on wamp server.

 

Here is the link of magento 2.2 technology stack - http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

Compare your wamp server 's each component with technology stack - like Apache Version , Php Version etc.

 

If its not compatible then installed version which is compatible with Magento 2.2 Technology stack.

 

Also refer this link for magento 2.2 installed on wamp http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

 

Then it will works !!

 

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2.2.2 installation

while installing magento 2.2 .I have got this error .I am new to this platform.So dont know about this where i have to change it.Please guide me

 

 

Fatal error: Declaration of Zend\Mvc\Controller\PluginManager::get($name, ?array $options = NULL) must be compatible with Zend\ServiceManager\AbstractPluginManager::get($name, $options = Array, $usePeeringServiceManagers = true) in C:\xampp\htdocs\igo\vendor\zendframework\zend-mvc\src\Controller\PluginManager.php on line 211

Re: Magento 2.2.2 installation

Generally this error occurs when your PHP Version is Not Supported and Not Compatible with your magento 2 setup.

 

So As mention above check your PHP version and compares with Magento 2 Technology stack here is the link - http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

Refer this link for more details - https://magento.stackexchange.com/questions/210278/declaration-of-zend-mvc-controller-pluginmanager-...

 

Note : While installing Magento 2 make sure all component of your software (wamp , xampp) like PHP version , Apache Version , Mysql version are compatible with the Magento 2 Technology stack.

 

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2.2.2 installation

My xampp PHP version is 7.1.12 which is compatible.

Re: Magento 2.2.2 installation

Yes 7.1.12 PHP Version is compatible.

 

Check your apache version which is needed 2.2 or 2.4

 

Also Make sure all the php extensions which is defined in technology stack are enabled .

 

if issue solved,Click Kudos & Accept as Solution