Showing results for 
Search instead for 
Did you mean: 

Magento 2.2 has the “Module 'Magento_ConfigurableSampleData' 68%” problem

Magento 2.2 has the “Module 'Magento_ConfigurableSampleData' 68%” problem

I am having the “Module 'Magento_ConfigurableSampleData': 68%” problem.


This problem has come up before, but none of the proposed solutions work.  I have tried all the various solutions I found on the Web and in Magento’s help files, but still having this problem.  Anyone have any other solutions? Am I missing anything obvious? Is there a way to insert a heartbeat into the code so I can mark its progress and debug further?


System details

My hosting service is DreamHost (with DreamCompute), my domain is <domain>, the server is <server> and it is running Ubuntu 14.04.5 LTS (as determined by executing “lsb_release -a”).  I access my user space with SSH using PuTTY on a Windows machine and all that works normally.  I access my user space using an FTP client, and all that works normally.  I log in to SSH as <user>.  The domain is configured so that its webroot is at /home/<user>/<domain>.

Checking that all the necessary pieces are in place:

[<server>]$ lsb_release -a

No LSB modules are available.

Distributor ID: Ubuntu

Description:    Ubuntu 14.04.5 LTS

Release:        14.04

Codename:       trusty

[<server>]$ cd ~

[<server>]$ pwd


[<server>]$ php -v

PHP 7.1.10 (cli) (built: Oct 13 2017 21:51:56) ( NTS )

Copyright (c) 1997-2017 The PHP Group

Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies

    with Zend OPcache v7.1.10, Copyright (c) 1999-2017, by Zend Technologies

[<server>]$ php --ini

Configuration File (php.ini) Path: /etc/php71

Loaded Configuration File:         /etc/php71/php.ini

Scan for additional .ini files in: /etc/php71/conf.d

Additional .ini files parsed:      /etc/php71/conf.d/imagick.ini,


[<server>]$ cat /home/<user>/.php/7.1/phprc

opcache.save_comments = 1

date.timezone = <filled in>


extension =

extension =

; always_populate_raw_post_data = -1

; set the max_execution_time to something unique to check that PHP is actually using my values

max_execution_time = 16123

; {{{ The following lines were automatically added by DreamHost

; }}} That's all from DreamHost

[<server>]$ cat /home/<user>/<domain>/phpinfo.php


// Show all information, defaults to INFO_ALL



From a regular browser, go to http://www.<domain>/phpinfo.php and it reports:

Core: max_execution_time         18000    16123 (Local Value, Master Value)


I reboot everything and come back the next day.  So, that tells me I am configured correctly, that I am accessing the right files via HTTP and all the settings have propagated.  (I don’t know if I am running nginx or Varnish.)


Next, installation:

                1) Downloaded tarball to Windows because there is no Magento permalink to the tarball Magento-CE-2.2.0_sample_data-2017-09-26-08-07-27.tar.gz

                2) FTP’ed the tarball to /home/<user>

                3) extracted it:

[<server>]$ tar -xvf /home/<user>/<domain>/ Magento-CE-2.2.0_sample_data-2017-09-26-08-07-27.tar.gz ./<domain>

                4) Set up fresh database and provided it the appropriate permissions and users.  I know setup has permissions because it goes to 70 MB or so during install.

                5) From a regular browser, I go to http://www.<domain>/setup and run from there.  Readiness check clears, I enter the database details, customize the store be leaving all modules checked. “Step 6: Install   You're ready!”


I watch the console.  It gets to 68% and hangs on Module 'Magento_ConfigurableSampleData': 68%”

Delete the database and start back on step 4 and repeat.  Same result.

Delete the entire directory from /home/<user>/<domain> down except for /home/<user>/<domain>/phpinfo.php and reinstall from step 3.  Same result.

Repeat at step 3 and step 4 several times.


Read through all the suggestions at: