cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.2 wiht PHP 7.1 Extension update error

Magento 2.2 wiht PHP 7.1 Extension update error

Hello All,

I have installed Magento 2.2 with PHP 7.1. The installation went without problems. If I want to update the extension I get the following error message.


Check Component Dependency
We found conflicting component dependencies.
Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.10) does not satisfy that requirement.
- magenerds/language-de_de 1.0.2 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10].
- Installation request for magenerds/language-de_de 1.0.2 -> satisfiable by magenerds/language-de_de[1.0.2].

For additional assistance, see component dependency help .


regards Smiley Happy

1 REPLY

Re: Magento 2.2 wiht PHP 7.1 Extension update error

Hi,

 

I encountered the same problem (but with Magento 2.1.3). Here is a detailed solution https://www.goivvy.com/blog/magento-2-php-71 .