cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 - Plesk 12.5 on Centos 7 - Ownership issue

Magento 2 - Plesk 12.5 on Centos 7 - Ownership issue

I have managed to go through the installation ok with hiccups along the way but overall I have the install procedure on this platform figured out. 

 

For those who are interested:

 

1. Fresh Centos 7 install

2. Install MariaDB 10

3. Install Plesk

4. Update PHP to 5.6 using Remi repo (Not Plesk PHP but CLI php so it doesn't throw errors during install)

5. Install INTL and any other mods (just have a look at the requirements for magento to see which you need)

 

Now that Magento is "semi" installed I run into ownership/permission issues. I've attempted to use the procedure given in Magento 2 documentstion : apache : magento_user and vice versa etc.

 

It's not working on a Plesk install since we have an extra user group level to deal with ie: psacln, psaserv and the actual webuser assigned by Plesk automatically when you create a domain. 

 

I know its a permission/ownership issue since I've solved it by 775, 777'ing folders and files which were then properly read and folders were written to as well. 

 

However that is just a patch solution not destined for a live site. 

 

The permission issues are causing a lot of what other users have reported issues with ie. 40x,, 50x pages etc. because the server does not allow the client to read the page, and cannot write the required files to the server etc, 


If someone could give me the proper way of setting up the ownership and permission setting for a Plesk installation I think we would have a working setup for Magento 2 and Plesk 12.5


I would then be able to share it with everyone here as a working example giving detailed steps to make it work.

 

I know having plesk and magento together is not the ideal situation as Plesk does not support varnish (properly) etc. but its just convenient to use since mail, databases etc. etc. are easy to work with, especially when you have a couple websites that you need to run. 

 

Tags (1)
4 REPLIES

Re: Magento 2 - Plesk 12.5 on Centos 7 - Ownership issue

Were you able to determine the proper permissions settings when using Plesk? I am facing the same issue.

Re: Magento 2 - Plesk 12.5 on Centos 7 - Ownership issue

Same here

Re: Magento 2 - Plesk 12.5 on Centos 7 - Ownership issue

Hi there,

 

We have many Magento 2 clients running on Plesk 12 , Varnish and PHP 7 without any problems with permissions.

We use php in cgi mode (it uses system(ftp) user)
Plesk has on option to install several php versions, we do not do anything with main php and change domain settings in Plesk to use PHP 7 fastcgi for sites with Magento 2

before installation we change folders to 755 permissions and files to 644 with user to ftpuser.psacln (but you do not need to do this if you uploaded files by FTP).

 

just upload magento files using domain's ftp and set domain to use php fastcgi in hosting settings: https://dl.dropboxusercontent.com/s/ep6jolvzixpopsy/shot_160927_183539.png
php path for magento crons:
*/1 * * * * /opt/plesk/php/7.0/bin/php -c /opt/plesk/php/7.0/etc/php.ini /var/www/vhosts/YOURDOMAIN.com/httpdocs/bin/magento setup:cron:run
*/1 * * * * /opt/plesk/php/7.0/bin/php -c /opt/plesk/php/7.0/etc/php.ini /var/www/vhosts/YOURDOMAIN.com/httpdocs/bin/magento cron:run
*/1 * * * * /opt/plesk/php/7.0/bin/php -c /opt/plesk/php/7.0/etc/php.ini /var/www/vhosts/YOURDOMAIN.com/httpdocs/update/cron.php

 

hope this helps.

 

Anton Pachkine @ magento2.hosting : Magento Managed Package. Get your e-commerce health checkup at http://ecommerce.fitness

Re: Magento 2 - Plesk 12.5 on Centos 7 - Ownership issue

i am also running into this issue, i have followed the pre-installation permission setup as described here: http://devdocs.magento.com/guides/v2.0/install-gde/prereq/file-system-perms.html and created a user for magento.

 

but when switching to the new user i cannot do anything with it since permissions are denied on all operations.

 

I had previously installed magento as root and then changed ownership permissions after the fact to the plesk user and psaserv group and that worked but is a bit tedious to have to change user/group everytime i do something. i am now re-installing fresh because i messed up during migration so this time i wanted to do it by the book.

 

for some reason i cannot change to the Plesk user of this vhost with

su - <username>

when i try this i don't get an error message and the user stays root and all files created are root:root.

 

I also tried adding the new magento user to the psaserv group instead of the apache group but am still getting permission denied on most operations.

 

i'm on Centos 7.2.1511 with PHP 7.0.11 and Plesk 12.5.3 and php is running as FPM Application served by Apache