cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 community edition problem redirecting http: to https:

SOLVED

Magento 2 community edition problem redirecting http: to https:

I'm unable to re-direct my currently installed Magento 2 community edition from http: to https:

I have an SSL certificate but I called Go daddy and they told me to edit .htaccess in the root directory and add this code:

 

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

 

But after saving the file, I went to test my site and it's giving me this error message

This page isn’t working

redirected you too many times.

6 REPLIES

Re: Magento 2 community edition problem redirecting http: to https:

Hi @Hawaiian_Time,

 

Is it possible to see your URL configuraiton on Magento? (the secure and unsecure URL settings)

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Magento 2 community edition problem redirecting http: to https:

Hello Damian,

Thank you for the response. Here are the base and base secure URLs.

My site seems to working but when i first open up a browser and type in gcenterprise.net, google chrome is showing Not Secure. But when I click on sign-in, I see https:// on the browser and when i click back to the LUNA logo, it's on https://

How do I make it where is automatically will got to https:// when I first open up the browser to gcenterprise.net for the first time? Thank you.

Re: Magento 2 community edition problem redirecting http: to https:

Hi @Hawaiian_Time,


(Sorry for the delay, I was on travelling).

It seems is working perfectly. Did you found another issue?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Magento 2 community edition problem redirecting http: to https:

Aloha Damien,

Yes I finally got it to work. I went to Stores - Configuration - Web and just changed the base URL to https:.

Now, i have another issue. I tried to change the LUMA logo. I followed the steps:

Store - Design - Configuration - Default Store View - Header - to change logo. After I click Save Configuration, I'm getting this error Invalid scope or scope id.

 

I even tried to go to the back end change the logo.svg and no change.

 

Thank you for your help.

 

Kali

Tags (2)

Re: Magento 2 community edition problem redirecting http: to https:

@Hawaiian_Time

I was also facing same issue for my website www.paperlicense.com. SSL was loading for backend but not for the homepage of store front. It was giving me "Unsecure Connection" message on browser address bar. When I logged in as customer to storefront, then SSL used to start working. 

 

You solution of setting base url also to https worked for me. Simple perfect solution.

 

Thanks a lot for saving my hell lot of time that I would have spent in troubleshooting the root cause of problem.

 

Dev

Re: Magento 2 community edition problem redirecting http: to https:

You're welcome. I'm a new to Magento and learning as i go along.

 

Hawaiian Time