cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 installation stuck at 66%

Magento 2 installation stuck at 66%

Hello,

 

for two days now I've been trying to install Magento 2 on my shared server. It's a nightmare!

 

for php I have set .htaccess this way:

php_value always_populate_raw_post_data -1
php_value xdebug.max_nesting_level 500
php_value memory_limit 256M
php_value max_execution_time 18000

 

and for MySQL:  max_allowed_packet is set to 32MB 

 

and it always get's stuck at 66% with  problem:  [ERROR] exception 'Exception' with message 'Warning: Error while sending QUERY packet.

 

What does it want? How can I fix it?

 

At least, can you send me  clean DB for Magento 2 so I can directly upload it so maybe it skips installing SQL script.

8 REPLIES

Re: Magento 2 installation stuck at 66%

Re: Magento 2 installation stuck at 66%

It didn't solve it. Still the same  problem Smiley Sad

Re: Magento 2 installation stuck at 66%

I get his a lot if I try to install Magento 2 in the browser, I tend to use the `bin/magento` tool to install now, here is an example of the command:

 

bin/magento setup:install --db-host=localhost --db-name=magento --db-user=root --db-password=123 --base-url=http://magento2.dev/ --backend-frontname=admin --admin-firstname=Admin --admin-lastname=admin --admin-email=brideo@example.com --admin-user=admin --admin-password=password

Re: Magento 2 installation stuck at 66%

I'm having this issue also.  I don't have root access, so I am using the web installer.

 

Does anyone know of a solution?

 

Thanks!

Re: Magento 2 installation stuck at 66%

For anyone else that stumbles across this issue: 

Just crank up the max_allowed_packet mySQL global parameter.

 

SHOW VARIABLES LIKE 'max_allowed_packet';

set global max_allowed_packet=67108864;

Re: Magento 2 installation stuck at 66%

Has anyone found a solution to this problem?
I set the value of max_allowed_packet to 67108864 but it doesn't solve the problem

Re: Magento 2 installation stuck at 66%

In your php.ini file increase values of below parameters.

 

  • max_execution_time = 18000
  • max_input_time = 1800
  • memory_limit = 1024M

Note : Make sure you increase max_input_time value to at least 1800 and it will works !! 

 

 

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2 installation stuck at 66%

That did not work for me