cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 on Ubuntu 16

Magento 2 on Ubuntu 16

So, I just downloaded Magento-CE-2.1.0. I use Ubuntu 16.04 and the php version is 7.0.4-7ubuntu2.

But I got this error when I wanted to run Magento:

'Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please read Magento System Requirements.'

What should I do? Can't we run Magento on ubuntu 16?

 

6 REPLIES

Re: Magento 2 on Ubuntu 16

Hi @miladaz, does this help clarify the PHP requirements on Ubuntu? http://devdocs.magento.com/guides/v2.0/install-gde/prereq/php-ubuntu.html

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Magento 2 on Ubuntu 16

Yeah. But isn't there any way that'd help me to run Magento on this computer? What should I do?

Re: Magento 2 on Ubuntu 16

At what point did you get the error @miladaz? You should be fine with your version of PHP.

 

What version of Magento are you trying to install?

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Magento 2 on Ubuntu 16

The file is Magento-CE-2.1.0_sample_data-2016-06-23-02-34-07.tar.gz

Re: Magento 2 on Ubuntu 16

Hi @miladaz, have you tried following these installation instructions? http://devdocs.magento.com/guides/v2.0/install-gde/continue.html

 

Also here's a guide to our sample data since you're using it: http://devdocs.magento.com/guides/v2.0/install-gde/install/sample-data.html

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Magento 2 on Ubuntu 16

Currently, the Magento 2.1.0 composer.json doesn't allow PHP 7.0.4 but our testing confirms PHP 7.0.4 works.

 

You have two options: edit composer.json manually or use a different version of PHP. Up to you.