cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 setup: PHP Settings Check error

SOLVED

Magento 2 setup: PHP Settings Check error

In the very first screen of the Magento 2 installer, the PHP Ssettings Check says that I need to set this in php.ini...

always_populate_raw_post_data = -1

I set it appropriately (or uncommented it) in in all 3 of my php.ini files and did "service httpd restart" to restart Apache but it keeps on complaining? Any ideas? I also reboot the webserver to and no go.

Tags (1)
5 REPLIES

Re: Magento 2 setup: PHP Settings Check error

Here are the files I edited on CentOS 7:

  • /etc/php.ini
  • /opt/rh/php55/root/etc/php.ini
  • /etc/opt/rh/rh-php56/php.ini

Re: Magento 2 setup: PHP Settings Check error

Ahhhh ha. I created a phpinfo() file and found there was another php.ini file. In FCGi there is also a php.ini file for each user account. At the time of account creation in Virtualmin (similar to cPanel), it copies the main /etc/php.ini file (or wherever it is) but it isn't linked so either requires manual updating or running this to update all your php.ini files for all domains like this:

 virtualmin modify-php-ini --all-domains --ini-name always_populate_raw_post_data --ini-value -1

Then in CentOS 7 restart Apache...

systemctl restart  httpd.service

 

Re: Magento 2 setup: PHP Settings Check error

In my case, I solved the issue:

Update the line in the php.ini file to 

always_populate_raw_post_data = -1 

Copy this  corrected php.ini file to the setup folder.

Ran readiness check again and it passed.

Re: Magento 2 setup: PHP Settings Check error

Yes, that is ultimately the solution... the trick is to make sure you are editing the right php.ini file. It's kind of a global file when using mod_php, but there are typically separate php.ini files per domain if you're using mod_fcgid.

Re: Magento 2 setup: PHP Settings Check error

No, unfortunately it doesn't work for me, the PHP Settings Check still stuck there and preventing me from going further.

 

I downloaded magento 2.1.5 and hosted on Bluehost

php.ini in public_html as well as the magento root/setup are same and always_populate_raw_post_data = -1