cancel
Showing results for 
Search instead for 
Did you mean: 

Magento Readiness Check

Magento Readiness Check

Hello

I have an intranet server running Ubuntu 18.04 which I installed lamp, php, mysql and cubecart. Ive decided to install magento community alongside cubecart to compare and see which one I can get on better with.

On first running the magento install I got an error saying mcrypt, soap and bcmath were not installed and that I was running a wrong version of php.

Ive installed mcrypt, soap and bcmath, and the only error I get is:

"Your PHP version is 7.2.5-0ubuntu0.18.04.1. The required PHP version is 7.0.2|7.0.4|~7.0.6|~7.1.0."

If I read it right its saying it needs an older version of php ?????? Or is there a way ofchanging some setup file to allow me to use the current version I have.

 

Thanks

Phillip

5 REPLIES

Re: Magento Readiness Check

Can anyone help with this ? Is it ok to run two versions of php on a server ?

Thanks

Phillip

Re: Magento Readiness Check

Upto Magento 2.2.* Version, Magento is not support PHP 7.2.* version,

 

You need to downgrade your version to PHP 7.0.2|7.0.4|~7.0.6|~7.1.0

 

So your installation error will be wiped out.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Magento Readiness Check

Hi

I cant downgrade php as Ive already got a server setup with a website, plex, cubecart and other stuff, so cant justify downgrading and pinning php. Worse case scenario is magento works but everything else on my server fails.

Re: Magento Readiness Check

You dont have any issue for running two PHP on a server, Because you must need to install php version which is suitable for your magento 2 installation.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Magento Readiness Check

@phillip_chandler

 

Hi Phillip,

 

I am sure you must have read the requirement to install Magento. Same can be found on below URL.

 

https://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

If you want to install it on the same server where you already have other software then the only way you have is to have multiple version of PHP on the same server. It normally does not cause any issue and you  must be able to run different program on same server requires different version of PHP.

 

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

 

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter