cancel
Showing results for 
Search instead for 
Did you mean: 

Magento compatibility with MYSQL

Magento compatibility with MYSQL

Magento 2.0   Seems i am seeing conflicting information.

 

PHP 5.6.x or 5.5.x (PHP 5.4 is not supported)

 

 

Sorry, but we support MySQL version 5.6.0 or later.

 

 

 

Can i get a confirmation, if it is just 5.6.

12 REPLIES

Re: Magento compatibility with MYSQL

PHP version != MySQL version

Re: Magento compatibility with MYSQL

Magento 2.0 does also indeed support PHP 5.5 according to the documentation.

http://devdocs.magento.com/guides/v2.0/install-gde/prereq/php-centos.html

Re: Magento compatibility with MYSQL

Yes we support PHP 5.5, but the initial question was regarding this message.

 

Sorry, but we support MySQL version 5.6.0 or later.

Re: Magento compatibility with MYSQL

Yes we support PHP 5.5, but the initial question was regarding this message.

Sorry, but we support MySQL version 5.6.0 or later.

 




 

Re: Magento compatibility with MYSQL

Do you know of a way to get around this?

 

I'm stuck on step 2 of the installation. 1and1 is my host.  MySQL version 5.5.  

Error message "Sorry, but we support MySQL version 5.6.0 or later."

Re: Magento compatibility with MYSQL

I had my hosting provider upgrade my sql server to 5.6 for me. Granted it is a vps server and I have a little more control over it,see if they can move you to a server with it or find a cheaper host.

Re: Magento compatibility with MYSQL

Is there anyone that have an answer for this? 

If I upgrade to 5.6 I have other problems...

Re: Magento compatibility with MYSQL

If you are on fresh ubuntu server, you can install MySQL 5.6 by using this command.

 

sudo apt-get install mysql-server-5.6

Or upgrade your MySQL server to 5.6 by following these steps.

 

Step 1 : Take databases backup

 

mysqldump --lock-all-tables -u root -p --all-databases > dump.sql

Step 2 : Remove old version of MySQL

sudo apt-get remove mysql-server
sudo apt-get autoremove

Step 3 : Install new version of mysql

 

sudo apt-get install mysql-client-5.6 mysql-client-core-5.6
sudo apt-get install mysql-server-5.6

Step 4 : Restore your databases

mysql -u root -p < dump.sql

Re: Magento compatibility with MYSQL

Hi there,

I am not a coder but i have build a few really good websites on Wordpress, I have recently joined a new company that will be launching an online retail store and there web development team is using Magento. I will have to manage and update it. Im busy trying to download it on to my mamp local pc so i can play around with it.
I got to a point where is says "Sorry, but we support MySQL version 5.6.0 or later"

I downloaded the latest version of mamp and it has version 7.0. I have selected 7.0 on the mamp settings, but the error is still coming up? what do i have to do?

Thanks
Shahil Maharaj
South Africa