cancel
Showing results for 
Search instead for 
Did you mean: 

Magento detects a wrong php version in multiPHP envirornment of WHM / cpanel

SOLVED

Magento detects a wrong php version in multiPHP envirornment of WHM / cpanel

Hi everyone, 

I have installed Magento 2 and want to transfer data from a v.1.8.1.0 store with the Magento Data Migration Tool. 

The default php version on the server is 5.5.38 but the actual M2 account is on php 7.0.14
There is an option in cpanel where you can select a different php version, therefore the versions are different for the server and the actual account on the same server.

When I run 'phpinfo' or 'php -v', I get php v.7.0.14 but when I am installing the Data Migration Tool in ssh, it detects v.5.5.38.

 

Is there a solution or a workaround for this?

 

wrong-php.png

Thanks.

1 REPLY

Re: Magento detects a wrong php version in multiPHP envirornment of WHM / cpanel

I have figured out that it's not Magento and not the Data Migration Tool that is checking php version but the Composer! The solution is forcing Composer to ignore requirements with --ignore-platform-reqsoption. Like so:

composer config repositories.magento composer https://repo.magento.com
composer require magento/data-migration-tool:<version> --ignore-platform-reqs