cancel
Showing results for 
Search instead for 
Did you mean: 

Magento2.1 not loading css, js and admin panel after installation.

Magento2.1 not loading css, js and admin panel after installation.

I have installed magento2.1 CE. And it is not loading css, js and admin panel also. I have set web/seo/use_rewrites to 0, but still admin is not loading.

According to online forums, I have also tried to remove contents under pub/static (excpt .htaccess) and changed the recommended path to 

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink to 

Magento\Framework\App\View\Asset\MaterializationStrategy\Copy, and cleared var. But still nothing happened, no loading of css, js and admin panel.

Also, running this command : 

php bin/magento setup:static-content:deploy

 I keep getting this error : 

 

PHP Fatal error: Uncaught Error: Class 'Locale' not found in /var/www/html/fastcure-m2/vendor/magento/framework/Locale/Bundle/DataBundle.php:64
Stack trace:
#0 /var/www/html/fastcure-m2/vendor/magento/framework/Locale/Bundle/DataBundle.php(28): Magento\Framework\Locale\Bundle\DataBundle->cleanLocale('en_US')
#1 /var/www/html/fastcure-m2/vendor/magento/framework/Setup/Lists.php(80): Magento\Framework\Locale\Bundle\DataBundle->get('en_US')
#2 /var/www/html/fastcure-m2/vendor/magento/framework/Validator/Locale.php(42): Magento\Framework\Setup\Lists->getLocaleList()
#3 /var/www/html/fastcure-m2/vendor/magento/module-deploy/Console/Command/DeployStaticContentCommand.php(107): Magento\Framework\Validator\Locale->isValid('en_US')
#4 /var/www/html/fastcure-m2/vendor/symfony/console/Symfony/Component/Console/Command/Command.php(257): Magento\Deploy\Console\Command\DeployStaticContentCommand->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#5 /var/www/html/fastcure-m2/v in /var/www/html/fastcure-m2/vendor/magento/framework/Locale/Bundle/DataBundle.php on line 64

 

It is not at all working out for me and I am not able to understand what can possily go wrong after all the dependecy checks and installation?

2 REPLIES

Re: Magento2.1 not loading css, js and admin panel after installation.

Did you make the changes to the pub/static folder before or after trying to deploy the static content from the CLI? Your browser web tools should show a 404 for each missing file. If the content is not deployed to the correct location then you will encounter problems. Ensure that you run the deploy before you alter the folder and then cross reference the URL's to check the content is in place. Worst case I could just zip the files you need and send them over. However I would try an install from scratch and see if you can get it working out of the box.

Re: Magento2.1 not loading css, js and admin panel after installation.

I am having the exact same issues, i have tried to install it now four times each time is the same result. I am running centos 7, Checks go fine, it installs, but when I click on the links nothing happens, CSS does not work, it works when i go into the update folder. Admin page is not there, there is no directory for it in my server, this a standalone server.