cancel
Showing results for 
Search instead for 
Did you mean: 

Magento2 installation showing outdated module issue

Magento2 installation showing outdated module issue

I am setting up the magento2.2.2 with docker container. This is the error message i get after installation process is over.

 

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please update your modules: Run "composer install" from the Magento root directory.
The following modules are outdated:
Magento_Directory db schema version: defined in codebase - 2.0.1, currently installed - 2.0.2
Magento_Directory db data version: defined in codebase - 2.0.1, currently installed - 2.0.2
Magento_Catalog db schema version: defined in codebase - 2.2.3, currently installed - 2.2.4
Magento_Catalog db data version: defined in codebase - 2.2.3, currently installed - 2.2.4
Magento_Sales db schema version: defined in codebase - 2.0.7, currently installed - 2.0.9
Magento_Sales db data version: defined in codebase - 2.0.7, currently installed - 2.0.9
Magento_Tax db schema version: defined in codebase - 2.0.2, currently installed - 2.0.3
Magento_Tax db data version: defined in codebase - 2.0.2, currently installed - 2.0.3

Exception #0 (Magento\Framework\Exception\LocalizedException): Please update your modules: Run "composer install" from the Magento root directory.
The following modules are outdated:
Magento_Directory db schema version: defined in codebase - 2.0.1, currently installed - 2.0.2
Magento_Directory db data version: defined in codebase - 2.0.1, currently installed - 2.0.2
Magento_Catalog db schema version: defined in codebase - 2.2.3, currently installed - 2.2.4
Magento_Catalog db data version: defined in codebase - 2.2.3, currently installed - 2.2.4
Magento_Sales db schema version: defined in codebase - 2.0.7, currently installed - 2.0.9
Magento_Sales db data version: defined in codebase - 2.0.7, currently installed - 2.0.9
Magento_Tax db schema version: defined in codebase - 2.0.2, currently installed - 2.0.3
Magento_Tax db data version: defined in codebase - 2.0.2, currently installed - 2.0.3
#0 /var/www/html/magento2/lib/internal/Magento/Framework/Interception/Interceptor.php(121): Magento\Framework\Module\Plugin\DbStatusValidator->beforeDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Magento\Framework\App\Request\Http))
#1 /var/www/html/magento2/app/code/Magento/PageCache/Model/App/FrontController/BuiltinPlugin.php(73): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#2 /var/www/html/magento2/lib/internal/Magento/Framework/Interception/Interceptor.php(135): Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#3 /var/www/html/magento2/lib/internal/Magento/Framework/Interception/Interceptor.php(153): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#4 /var/www/html/magento2/generated/code/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#5 /var/www/html/magento2/lib/internal/Magento/Framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#6 /var/www/html/magento2/lib/internal/Magento/Framework/App/Bootstrap.php(256): Magento\Framework\App\Http->launch()
#7 /var/www/html/magento2/pub/index.php(37): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#8 {main}

To solve the problem I tried to ./magento setup:upgrade but that does not have effects too.

How do i solve this problem totally stuck

5 REPLIES

Re: Magento2 installation showing outdated module issue

Hi @taragurung,

 

Did you tried to run first, from the project root:

 

composer install
--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Magento2 installation showing outdated module issue

That didn't solve either

Re: Magento2 installation showing outdated module issue

Have you try to run command from root
`composer update`
Error shows that your components have older version than expected.
If Issue Solved, Click Kudos/Accept As solutions.

Re: Magento2 installation showing outdated module issue

As its Shows Localized Exceptions with outdated module version to resolve it follow below steps and run commands in sequence :

 

  • rm -rf  var
  • chmod 775 -R *
  • composer update && composer install
  • php -f bin/magento setup:static-content:deploy
  • find . -type d -exec chmod 775 {}
  • find . -type f -exec chmod 660 {}
  • chmod u+x bin/magento
  • bin/magento cache:clean
  • bin/magento cache:flush

 

if issue solved, Click kudos/Accept as solutions.

if issue solved,Click Kudos & Accept as Solution

Re: Magento2 installation showing outdated module issue

Thanks! I couldn't do the "find. -type...": commands, but I think the prior commands might have helped!