cancel
Showing results for 
Search instead for 
Did you mean: 

Migration Tool: Data EAV incorrect values

Migration Tool: Data EAV incorrect values

Hi Everyone,

 

I am in the process of using the Migration tool to go from 1.9.2.1. I've hit a few hurdles but on the most part I have managed to debug the issues myself with the documentation.

 

That said I am stuck on how to solve these errors:

[2016-01-20 21:58:57][ERROR]: Incorrect value: megamenu/category_attribute_source_type_style in: eav_attribute.source_model for attribute_code=sw_cat_block_type
[2016-01-20 21:58:57][ERROR]: Incorrect value: megamenu/category_attribute_source_block_subcolumns in: eav_attribute.source_model for attribute_code=sw_cat_block_columns
[2016-01-20 21:58:57][ERROR]: Incorrect value: megamenu/category_attribute_source_block_columns in: eav_attribute.source_model for attribute_code=sw_cat_left_block_width
[2016-01-20 21:58:57][ERROR]: Incorrect value: megamenu/category_attribute_source_block_columns in: eav_attribute.source_model for attribute_code=sw_cat_right_block_width
[2016-01-20 21:58:57][ERROR]: Incorrect value: megamenu/category_attribute_source_label_categorylabel in: eav_attribute.source_model for attribute_code=sw_cat_label
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_1
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_2
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_3
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_4
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_5
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_attribute_tab_1
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_attribute_tab_2
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_attribute_tab_3
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_attribute_tab_4
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_attribute_tab_5
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_6
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_7
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_8
[2016-01-20 21:58:57][ERROR]: Incorrect value: porto/category_attribute_source_tab_mode in: eav_attribute.source_model for attribute_code=sw_product_staticblock_tab_9

I think based on the map.xml and config.xml and ignoring custom tables/fields I probably need to do something in another xml file but I have no idea which and I haven't managed to find anyone else talking about this kind of issue?

I would really appreciate it if someone could point me in the right direction.

Thanks,
Simon

2 REPLIES

Re: Migration Tool: Data EAV incorrect values

Sorry for the bump but is my issue something that nobody else experienced or is the answer so obvious that I shouldn't have even asked? If someone could put me out of my misery either way that would excellent Smiley Happy

Re: Migration Tool: Data EAV incorrect values

I don't have a lot of technical knowledge. Last month I used a migration tool to upgrade Magento to version 2.0 and it works well with no bug. I found it on magentocommerce site. You can try https://www.magentocommerce.com/magento-connect/magento-to-magento-migration-tool.html