cancel
Showing results for 
Search instead for 
Did you mean: 

Missing extension on installing Magento 2 on Ubuntu PHP 5.6

Missing extension on installing Magento 2 on Ubuntu PHP 5.6

Hope someone could give me idea.

 

I've been struggling on installing magento 2 on ubuntu 16 where php 5.6 is installed. It always warns extension intl and zip missing so the readiness check could not be passed.

 

My machine ubuntu 16 has php 7 by default installed but for a migration issue I must let the php 5.6 running. I checked Magento 2 can also supported by 5.6.

 

I have tried installing multiple versions php e.g. php 7.0.x also installed. I switched to php 7.0, the readiness check passed. However, my app on php 5.6 crashed.

 

I tried apt-get install php-intl & php-zip, it always installed for me php7.0 extension no matter my CLI php is 5.6 or 7.0, I checked that by php -v

 

I tried apt-get install php5.6-intl and php5.6-zip as someone suggested on Internet, it just failed with package not found.

 

Will you have any idea? Thanks in advance.


-=-=-=-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=
I'm always a child when talking about knowledge.
Tags (1)
3 REPLIES

Re: Missing extension on installing Magento 2 on Ubuntu PHP 5.6

If php56-intl doesn't work. Can you try this instead:

 

sudo apt-get update
sudo apt-get install php5-intl

What version of Magento are you trying to install. Up to Magento 2.1.x php 5.6 is supported. If you're installing Magento 2.2, then you will need to use a compatible version of PHP 7 http://devdocs.magento.com/guides/v2.1/install-gde/system-requirements-tech.html

 

If you can share the commands that you're running and their exact output that would help. Thanks.

 

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Missing extension on installing Magento 2 on Ubuntu PHP 5.6

Robert, thanks for your ideas.

 

# php -v
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20131226/intl.so' - /usr/lib/php/20131226/intl.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20131226/zip.so' - /usr/lib/php/20131226/zip.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.6.31-1~ubuntu16.10.1+deb.sury.org+1 (cli)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
with Xdebug v2.5.5, Copyright (c) 2002-2017, by Derick Rethans

 

# apt-get update

done without error

 

# apt-get install php-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
php-intl
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,920 B of archives.
After this operation, 11.3 kB of additional disk space will be used.
Selecting previously unselected package php-intl.
(Reading database ... 103617 files and directories currently installed.)
Preparing to unpack .../php-intl_1%3a7.0+44_all.deb ...
Unpacking php-intl (1:7.0+44) ...
Setting up php-intl (1:7.0+44) ...

 

>> strange it installed 7.0 stuff for me. I have remove php 7.0

 

# apt-get install php5-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-intl <------- error

 

# apt-get install php5.6-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5.6-intl
E: Couldn't find any package by glob 'php5.6-intl'
E: Couldn't find any package by regex 'php5.6-intl'

 

# apt-get install php56-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php56-intl

 

Done works other than php-intl, but that install php 7 for me.

 

The same for php-zip.

 

I installed Magento 2.1.9

 

_ 2018-01-15 22.52.53.jpg

 

 

 


-=-=-=-=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=
I'm always a child when talking about knowledge.

Re: Missing extension on installing Magento 2 on Ubuntu PHP 5.6

Hi,

 

Edit your php.ini file and un-comment or add below extensions

 

extension=php_intl.dll

extension=php-zip.dll

 

Also check if these .dll files are present under "/php/ext" folder. If not you need to install them and keep these files under "ext" folder. 

 

Restart your PHP services and try to reinstall. The error will be resolved.

 

Hope this helps

 


bcsssw wrote:

Robert, thanks for your ideas.

 

# php -v
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20131226/intl.so' - /usr/lib/php/20131226/intl.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20131226/zip.so' - /usr/lib/php/20131226/zip.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.6.31-1~ubuntu16.10.1+deb.sury.org+1 (cli)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
with Xdebug v2.5.5, Copyright (c) 2002-2017, by Derick Rethans

 

# apt-get update

done without error

 

# apt-get install php-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
php-intl
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,920 B of archives.
After this operation, 11.3 kB of additional disk space will be used.
Selecting previously unselected package php-intl.
(Reading database ... 103617 files and directories currently installed.)
Preparing to unpack .../php-intl_1%3a7.0+44_all.deb ...
Unpacking php-intl (1:7.0+44) ...
Setting up php-intl (1:7.0+44) ...

 

>> strange it installed 7.0 stuff for me. I have remove php 7.0

 

# apt-get install php5-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5-intl <------- error

 

# apt-get install php5.6-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5.6-intl
E: Couldn't find any package by glob 'php5.6-intl'
E: Couldn't find any package by regex 'php5.6-intl'

 

# apt-get install php56-intl
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php56-intl

 

Done works other than php-intl, but that install php 7 for me.

 

The same for php-zip.

 

I installed Magento 2.1.9

 

_ 2018-01-15 22.52.53.jpg