Showing results for 
Search instead for 
Did you mean: 

Multi-vendor module installation issue

Multi-vendor module installation issue

Hello everyone


I have purchased (multi-vendor, Social Signon, UV desk and Agorae) modules from Webkul.


I first tried to install it in the last month which was unsuccessful and I was bound to contact Webkul support. They installed the all the extensions which I couldn't go through them. Unfortunately the support period is over.


Now I am shifting to Digital Ocean as my cloud service provider and need to install multi-vendor and SSO (social signon) at my own.

I tried to do it myself. With some if and buts, I reached installed multi-vendor module but it is generating some errors.


On the top of the admin dashboard, it is generating the below error:

"One or more integrations have been reset because of a change to their xml configs."


While when I am going through the "Marketplace" links, none of them is working, with errors as listed below:


1. On clicking "Manage product", "Manage Seller" and "Manage Feedback", it is showing:

There has been an error processing your request

Exception printing is disabled by default for security reasons.

Error log record number: xxxxxxxxxxxx


2. Clicking "Manage Commission" it is generating, below error:

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'fdbase.marketplace_saleperpartner' doesn't exist, query was: SELECT COUNT(*) FROM `marketplace_saleperpartner` AS `main_table` INNER JOIN `customer_grid_flat` AS `cgf` ON main_table.seller_id = cgf.entity_id


3. Clicking on "Seller Transaction", it is generating:

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'fdbase.marketplace_sellertransaction' doesn't exist, query was: SELECT COUNT(*) FROM `marketplace_sellertransaction` AS `main_table`


There is no permission issue related to these.


Any idea??


Re: Multi-vendor module installation issue

Hi @The_Panwar,


I'm haven't installed these extension myself but looking at the error messages it seems like you have some database tables missing. Have you compared the old database to the new migrated one?

Re: Multi-vendor module installation issue

Hello Smith

Thanks for the reply.

I am working on a fresh installation. No old data/database I am using.

When MySQL is generating a generating a query "SELECT COUNT(*)" it is generating error because at point 2 saleperpartner table doesn't exist and  at point 3  sellertransaction table doesn't exist. I am unable to understand why it is happening.


Second thing is I am trying to install Webkul's Social sign in module by copying its purchased contents to /app/code/Webkul/SocialSignon and running SSH UCD (upgrade, compile, deploy) and after that cache clean and clear commands but I am not even able to get the link of Social login module in the admin panel.


Please suggest.

Re: Multi-vendor module installation issue

Hello.  I am having the same issue BUT paid Webkul for support AND they still did not get it to work.  Please share your site.  I'll like to see how the multi-vendor is working.  My site is but Webkul broke site installing the social icon module.