cancel
Showing results for 
Search instead for 
Did you mean: 

Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

SOLVED

Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Dear Whom It May Concern,

 

I have downloaded the latest Magento 2 from Magento Open Source. After deploying, the images and the alignment of the website are all out.

 

The troubleshooting steps that I have done are as below;

1. Added extension=php_xsl.dll and extension=php_intl.dll in php.ini

2. Install Win 10 IIS URL Rewrite

3. Create web.config as guided in http://www.gadjev.com/2016/02/08/installing-magento-ce-2-0-on-windows-server-2012-r2-iis-8-5/

4. Did a static deployment as guided in http://www.drupalonwindows.com/en/blog/installing-magento-windows-and-iis

 

Step 1 enable Magento to create the Admin page. However, the step 2, 3, 4 did not solve my alignment issue. The problem I am still getting is as below;

 

image (1).pngimage (2).pngimage (3).pngimage.png

 

 

 

 

10 REPLIES

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Hi @justin_pang

 

Looks like your screenshot may not visible to us !!

 

could you please post it somewhere else and share link here - or post exact error log which you are able to seen on your setup 

 

provide some more details on so it helps us to troubleshoot the issue 

if issue solved,Click Kudos & Accept as Solution

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Please check your magento instance with root has .htaccess file or not?

if you dont find .htaccess file, 

You need to put .htaccess file in your root of magento,

Keep below code for .htaccess

############################################
## overrides deployment configuration mode value
## use command bin/magento deploy:mode:set to switch modes

#   SetEnv MAGE_MODE developer

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>
############################################
## adjust memory limit

    php_value memory_limit 768M
    php_value max_execution_time 18000

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
## disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off
</IfModule>
<IfModule mod_php7.c>
############################################
## adjust memory limit

    php_value memory_limit 768M
    php_value max_execution_time 18000

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
## disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off
</IfModule>
<IfModule mod_security.c>
###########################################
## disable POST processing to not break multiple image upload

    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript application/x-javascript application/json image/svg+xml

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    SSLOptions StdEnvVars

</IfModule>

############################################
## workaround for Apache 2.4.6 CentOS build when working via ProxyPassMatch with HHVM (or any other)
## Please, set it on virtual host configuration level

##    SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
############################################

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

    RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
    RewriteRule .* - [L,R=405]

############################################
## redirect for mobile user agents

    #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
    #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
    #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    AddDefaultCharset Off
    #AddDefaultCharset UTF-8
    AddType 'text/html; charset=UTF-8' html

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    ExpiresDefault "access plus 1 year"
    ExpiresByType text/html A0
    ExpiresByType text/plain A0

</IfModule>

###########################################
## Deny access to root files to hide sensitive application information
    RedirectMatch 403 /\.git

    <Files composer.json>
        order allow,deny
        deny from all
    </Files>
    <Files composer.lock>
        order allow,deny
        deny from all
    </Files>
    <Files .gitignore>
        order allow,deny
        deny from all
    </Files>
    <Files .htaccess>
        order allow,deny
        deny from all
    </Files>
    <Files .htaccess.sample>
        order allow,deny
        deny from all
    </Files>
    <Files .php_cs.dist>
        order allow,deny
        deny from all
    </Files>
    <Files .travis.yml>
        order allow,deny
        deny from all
    </Files>
    <Files CHANGELOG.md>
        order allow,deny
        deny from all
    </Files>
    <Files CONTRIBUTING.md>
        order allow,deny
        deny from all
    </Files>
    <Files COPYING.txt>
        order allow,deny
        deny from all
    </Files>
    <Files Gruntfile.js>
        order allow,deny
        deny from all
    </Files>
    <Files LICENSE.txt>
        order allow,deny
        deny from all
    </Files>
    <Files LICENSE_AFL.txt>
        order allow,deny
        deny from all
    </Files>
    <Files nginx.conf.sample>
        order allow,deny
        deny from all
    </Files>
    <Files package.json>
        order allow,deny
        deny from all
    </Files>
    <Files php.ini.sample>
        order allow,deny
        deny from all
    </Files>
    <Files README.md>
        order allow,deny
        deny from all
    </Files>
    <Files magento_umask>
        order allow,deny
        deny from all
    </Files>

# For 404s and 403s that aren't handled by the application, show plain 404 response
ErrorDocument 404 /pub/errors/404.php
ErrorDocument 403 /pub/errors/404.php

################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

# ######################################################################
# # INTERNET EXPLORER                                                  #
# ######################################################################

# ----------------------------------------------------------------------
# | Document modes                                                     |
# ----------------------------------------------------------------------

# Force Internet Explorer 8/9/10 to render pages in the highest mode
# available in the various cases when it may not.
#
# https://hsivonen.fi/doctype/#ie8
#
# (!) Starting with Internet Explorer 11, document modes are deprecated.
# If your business still relies on older web apps and services that were
# designed for older versions of Internet Explorer, you might want to
# consider enabling `Enterprise Mode` throughout your company.
#
# https://msdn.microsoft.com/en-us/library/ie/bg182625.aspx#docmode
# http://blogs.msdn.com/b/ie/archive/2014/04/02/stay-up-to-date-with-enterprise-mode-for-internet-explorer-11.aspx

<IfModule mod_headers.c>

    Header set X-UA-Compatible "IE=edge"

    # `mod_headers` cannot match based on the content-type, however,
    # the `X-UA-Compatible` response header should be send only for
    # HTML documents and not for the other resources.

    <FilesMatch "\.(appcache|atom|bbaw|bmp|crx|css|cur|eot|f4[abpv]|flv|geojson|gif|htc|ico|jpe?g|js|json(ld)?|m4[av]|manifest|map|mp4|oex|og[agv]|opus|otf|pdf|png|rdf|rss|safariextz|svgz?|swf|topojson|tt[cf]|txt|vcard|vcf|vtt|webapp|web[mp]|webmanifest|woff2?|xloc|xml|xpi)$">
        Header unset X-UA-Compatible
    </FilesMatch>

</IfModule>

Run below command,

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento setup:di:compile
php bin/magento indexer:reindex
php bin/magento cache:flush

 

If Issue Solved, Click Kudos/Accept As solutions.

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Dear Rakesh,

 

There is a .htaccess file on the root folder. I have done screen-capture and attached log files on this shared folder.

 

https://drive.google.com/drive/folders/1FDVRD144E6YF2NxMFb31sza-MvI6c6iF?usp=sharing

 

Thank you for your kind assistance in advanced.

 

Regards,

Justin

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Dear Manthan,

 

I have included the print screen and log files in this shared folder.

https://drive.google.com/drive/folders/1FDVRD144E6YF2NxMFb31sza-MvI6c6iF?usp=sharing

 

Thank you for your kind assistance.

 

Regards,

Justin

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Hi @justin_pang (Justin)

 

I have seen the screenshot you have shared on the drive and it looks like magento 2 installed successfully on your windows system !!

 

But you required to run static-content:deploy command on it !!

 

Open your command prompt/SSH (command line) window - go to your magento 2 root directory and then you need to run below command :

 

php bin/magento setup:static-content:deploy -f
php bin/magento cache:clean
php bin/magento cache:flush

 Then check it will works for you !!

 

Hope it helps !!

if issue solved,Click Kudos & Accept as Solution

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Hi @ManthanDave,

 

Thank you for your prompt reply.

 

Unfortunately, I have tried the steps you have provided but I am still getting the same problem.

 

This time, the error I have got from Chrome developer mode is as the picture below;

18 errors.jpg

 

 

I have followed the troubleshooting steps as recommended from this website, https://devdocs.magento.com/guides/v2.1/config-guide/cli/config-cli-subcommands-static-view.html

 

But I am still getting an out of aligned website display. I would appreciate if you could suggest any more steps I can take to rectify this problem.

 

Thank you & have a nice day.

Justin

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Hi @justin_pang (Justin)

 

There should be a multiple reason for this kind of issue.

 

  • Check your pub/static folder of the magento 2 root directory is there .htaccess file is there or not ? full path is like magento2/pub/static/.htaccess - if not kindly put there
  • Second thing check apache2 rewrite_mode is available or not !! if not then enable rewrite_mode of apache2
  • Check versioning issue in db - write this query in database core_config_table - INSERT INTO 'core_config_data' ('path', 'value')
    VALUES ('dev/static/sign', 0)
    ON DUPLICATE KEY UPDATE value = 0;
  • Most important check your pub/static have 777 writable permission or not ? if not kindly give writable permission at least 775

 

This will work for you , check all the option one by one and check at frontend !!

 

Hope it helps

if issue solved,Click Kudos & Accept as Solution

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Hi @justin_pang

 

is your issue gets resolved ? let me know if you still have any issue on this ? 

if issue solved,Click Kudos & Accept as Solution

Re: Not successful deploy Magento 2 onto Win 10 IIS and PHP 7.1

Dear @ManthanDave,

 

Thank you for your follow up.

I have done every step that you have suggested above but to no avail. For the past few days, I have been trying to deploy Magento on Ubuntu-18.04-desktop-amd64. And the outcome is like from the frying pan into the fire.

 

I have installed based on the steps provided on this link, https://websiteforstudents.com/install-magento-on-ubuntu-16-04-17-10-18-04-with-apache2-mariadb-php-... , but the outcome is a Blank Page.

 

In addition, I have grant 777 permission in oppose to what has been suggested, 755, on the link above. It still does not work.

VM02.jpg

VM01.jpg