cancel
Showing results for 
Search instead for 
Did you mean: 

PHP Extensions Check soap must be loaded

Highlighted

PHP Extensions Check soap must be loaded

Hi all,

 

I try to install an Extensions through the backend but the checks failed because Soap extensions is "missing" but the server has the SOAP extensions installed, see the following output:

 

server@server.nl [~]# php -r 'echo (extension_loaded("soap")?"LOADED\n":"not loaded\n");'
LOADED


server@server.nl [~]# php -i | grep soap
Configure Command =>  './configure'  '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--program-prefix=' '--disable-dependency-tracking' '--prefix=/opt/cpanel/ea-php72/root/usr' '--exec-prefix=/opt/cpanel/ea-php72/root/usr' '--bindir=/opt/cpanel/ea-php72/root/usr/bin' '--sbindir=/opt/cpanel/ea-php72/root/usr/sbin' '--sysconfdir=/opt/cpanel/ea-php72/root/etc' '--datadir=/opt/cpanel/ea-php72/root/usr/share' '--includedir=/opt/cpanel/ea-php72/root/usr/include' '--libdir=/opt/cpanel/ea-php72/root/usr/lib64' '--libexecdir=/opt/cpanel/ea-php72/root/usr/libexec' '--localstatedir=/opt/cpanel/ea-php72/root/usr/var' '--sharedstatedir=/opt/cpanel/ea-php72/root/usr/com' '--mandir=/opt/cpanel/ea-php72/root/usr/share/man' '--infodir=/opt/cpanel/ea-php72/root/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/opt/cpanel/ea-php72/root/etc' '--with-config-file-scan-dir=/opt/cpanel/ea-php72/root/etc/php.d' '--disable-debug' '--with-pic' '--without-pear' '--with-bz2' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl=/opt/cpanel/ea-openssl' '--with-openssl-dir=/opt/cpanel/ea-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-sockets' '--with-kerberos' '--enable-shmop' '--with-libxml-dir=/opt/cpanel/ea-libxml2' '--with-system-tzdata' '--with-mhash' '--libdir=/opt/cpanel/ea-php72/root/usr/lib64/php' '--enable-pcntl' '--enable-opcache' '--disable-opcache-file' '--enable-phpdbg' '--with-imap=shared,/opt/cpanel/ea-php72/root/usr' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbregex' '--with-webp-dir=/usr' '--with-gd=shared' '--with-gmp=shared' '--enable-calendar=shared' '--enable-bcmath=shared' '--with-bz2=shared' '--enable-ctype=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-tcadb=/usr' '--enable-exif=shared' '--enable-ftp=shared' '--with-gettext=shared' '--with-iconv=shared' '--enable-sockets=shared' '--enable-tokenizer=shared' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--enable-mysqlnd=shared' '--with-mysqli=shared,mysqlnd' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--enable-dom=shared' '--with-pgsql=shared' '--enable-simplexml=shared' '--enable-xml=shared' '--enable-wddx=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-curl=shared,/opt/cpanel/libcurl' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,mysqlnd' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--with-sqlite3=shared,/usr' '--enable-json=shared' '--enable-zip=shared' '--without-readline' '--with-libedit' '--with-pspell=shared' '--enable-phar=shared' '--with-tidy=shared,/opt/cpanel/libtidy' '--enable-sysvmsg=shared' '--enable-sysvshm=shared' '--enable-sysvsem=shared' '--enable-shmop=shared' '--enable-posix=shared' '--with-unixODBC=shared,/usr' '--enable-intl=shared' '--with-icu-dir=/usr' '--with-enchant=shared,/usr' '--with-recode=shared,/usr' '--enable-fileinfo=shared' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -fno-strict-aliasing -Wno-pointer-sign' 'CXXFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic'
/opt/cpanel/ea-php72/root/etc/php.d/20-soap.ini,
soap
soap.wsdl_cache => 1 => 1
soap.wsdl_cache_dir => /tmp => /tmp
soap.wsdl_cache_enabled => 1 => 1
soap.wsdl_cache_limit => 5 => 5
soap.wsdl_cache_ttl => 86400 => 86400

server@server.nl [~]# php -v
ea-php-cli Copyright 2017 cPanel, Inc.
PHP 7.2.6 (cli) (built: May 29 2018 01:56:05) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

server@server.nl [~]# php -m | grep soap
soap

server@server.nl [~]# rpm -qa|grep soap
ea-php56-php-soap-5.6.36-1.1.6.cpanel.x86_64
ea-php70-php-soap-7.0.30-1.1.6.cpanel.x86_64
ea-php71-php-soap-7.1.18-1.1.1.cpanel.x86_64
ea-php72-php-soap-7.2.6-1.1.4.cpanel.x86_64

I tried to reinstall the SOAP extensions but unfornately no luck. I am a bit lost what to do now. Any tips?

Server have cPanel / WHM installed and I have fully root access to the machine.

1 REPLY

Re: PHP Extensions Check soap must be loaded

@morphezAll seems good in your screenshot. You can try below couple of things:

 

1. Try uploading a phpinfo file with the same command in it and browse to check if it shows soap in there.

2. Try restarting the PHP/Apache.

3. Extension could be buggy and not compatible with the PHP/Magento version you have and it may be throwing incorrect error.

4. Where did you see the error on the browser or log file? Server/Magento log may have more accurate error.

 

Problem solved? Please give 'Kudos' and accept 'Answer as Solution'.

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter