cancel
Showing results for 
Search instead for 
Did you mean: 

PHP INTL Extension Missing - CPANEL with PHP 5.5.30

SOLVED

PHP INTL Extension Missing - CPANEL with PHP 5.5.30

I have shared hosting; if you look at the following link you can see I have the required version of PHP and all extensions needed including INTL are enabled. 

 

I tried installing Magento through Installatron via CPANEL but was getting the PHP incorrect version error. 

 

I had my hosting provider upgrade the PHP from 5.4 to 5.5 

 

I then tried the install again and was getting the error that INTL is OFF

 

My hosting provider thought something was corrupt with the install and advised me to try and manually install. So I downloaded a clean copy of Magento and unzipped it to the root directory, it is still stating that it is not installed. My hosting provider still thinks it's Magento that's broken and not the server. Do you guys have any ideas that will help me get this functioning?

Missing INTL Screenshot

Tags (3)
3 REPLIES

Re: PHP INTL Extension Missing - CPANEL with PHP 5.5.30

Do they have the PHP extension INTL enabled in the server?

You can create a PHP Info page to confirm this:-
http://php.net/manual/en/function.phpinfo.php
James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: PHP INTL Extension Missing - CPANEL with PHP 5.5.30

I called the support desk and their tech had to reinstall it. Something went corrupt when they upgraded the PHP. 

 

It's sorted now, except for now they have to upgrade MySQL for me. lol Smiley LOL 

Re: PHP INTL Extension Missing - CPANEL with PHP 5.5.30

If you are using cPanel, following are the steps 

 

1) Login to WHM
2) Left side menu - locate "EasyApache 4" 

3) Click on "All PHP Options" . ( + option is optional, if you click "View All package" it show all the available extensions, PHP 7.0 , php-intl and php-zip )

4) Click "Customise" 

5) Go next next next 

6) Click "Provision"   ( it will take few minutes to install, have patience )

7) It will successfully install all the needed extensions to install Magento 2.0

 

Best wishes,

Deepak K Rana
IT Director, Amforma IT Private Ltd, India

www.amforma.com

 

screenshot-69.36.182.185-2087-2018.02.24-14-30-26.png

Tags (3)