cancel
Showing results for 
Search instead for 
Did you mean: 

PHP Settings Check fail displaying wrong memory limit

PHP Settings Check fail displaying wrong memory limit

My Server

 

Ubuntu 16.04

Managed by Serverpilot

Magento 2.1.0 CE

mysql 5.7

apache 2.4 with nginx

php 7

 

Trying to install a extension through Component manager I get the error below.

 

PHP Settings Check *

Your current PHP memory limit is 256M. Magento 2 requires it to be set to 756M or more. As a user with root privileges, edit your php.ini file to increase memory_limit. (The command php --ini tells you where it is located.) After that, restart your web server and try again.

 

Thing is my memory limit is 768m.. If i go to phpinfo.php it shows that my local value is 768M and my master value is 256M.   So my local value says my memory limit is correct.  I don't think i could have installed magento 2 if my memory limit was 256M.   I used serverpilots recommended using .user.ini file in magento root to change the memory limit.

 

Also state that this a migration using the migration tool from 1.9.2.1 to 2.1.0.. migration went fine.. But wonder if it brought over some file that has the wrong value that the check is seeing... don't know..  Please help.. i need my extension...

 

20 REPLIES

Re: PHP Settings Check fail displaying wrong memory limit

Both my local value and master value is 768M and I still have the problem?

 

I did a fresh install of magento 2.1 using softaculous.

 

php 5.6.10

Re: PHP Settings Check fail displaying wrong memory limit

Hi buddy, did you already found some solution to this issue?

Re: PHP Settings Check fail displaying wrong memory limit

No still looking for a solution, have you found anything?

Re: PHP Settings Check fail displaying wrong memory limit

Your server is managed by Server Pilot??

what have they said?

What do your nginx logs have?. Anything?

Developer

Re: PHP Settings Check fail displaying wrong memory limit

I'm having the same issue. Both web phpinfo.php and php -i via command line are showing the memory_limit is 2G, yet this error is still coming up during readiness check.

Re: PHP Settings Check fail displaying wrong memory limit

Im going to try v2.1.1 soon to see if anythings changed.

Re: PHP Settings Check fail displaying wrong memory limit

I'm having the same problem

Any solutions?

Re: PHP Settings Check fail displaying wrong memory limit

I am having the same issue whilst trying to upgrade. I initially got the message when upgrading - tried setting the limit to 756M in WHM with no luck, tried setting the memory limit using .user.ini with no change. Check the memory limit using phpinfo which confirms the limit is 756M but the Magento reediness checker refuses to accept the limit:

 

---

Your current PHP memory limit is 32M. Magento 2 requires it to be set to 756M or more. As a user with root privileges, edit your php.ini file to increase memory_limit. (The command php --ini tells you where it is located.) After that, restart your web server and try again.

---

Tags (3)

Re: PHP Settings Check fail displaying wrong memory limit

hi guys,

 

did you ask your hosting support to help with this? any decent host will adjust php settings for you or at least suggest you how to fix it on that server if server is unmanaged. sometimes, the fix is as easy as rebooting the server or restarting nginx and httpd.

 

Anton Pachkine @ magento2.hosting : Magento Managed Package. Get your e-commerce health checkup at http://ecommerce.fitness