cancel
Showing results for 
Search instead for 
Did you mean: 

PHP Settings Check magento 2 error

SOLVED

PHP Settings Check magento 2 error

Hello I am having a problem with the installation of magento 2 I am having this problem with MAMP :

 

PHP Settings Check

Your PHP Version is 5.6.10, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

For additional assistance, see PHP settings check help .

 

 

Tags (1)
47 REPLIES

Re: PHP Settings Check magento 2 error

1.Open your php.ini file,

2. Find always_populate_raw_post_data, uncomment the line and set it to -1,

3 .Save php.ini

4. Restart php or your web server.

Re: PHP Settings Check magento 2 error

Thanks for your response the php.ini file is located or?

Re: PHP Settings Check magento 2 error

I don't know which OS you are using, so try

https://www.google.com/search?q=php.ini+location&ie=utf-8&oe=utf-8

Re: PHP Settings Check magento 2 error

I am el capitan Mac.

Re: PHP Settings Check magento 2 error

You can find out the php.ini files location (actually, the PHP interpreter can use multiple php.ini files at once) by running the phpinfo() function from your Magento 2 website root: http://php.net/manual/function.phpinfo.php

Re: PHP Settings Check magento 2 error

Did you get this fixed? I have same problem but when i change to -1 nothing happens. Can someone tell me exactly the line i need to put in were? Im running mamp and IOS-

Re: PHP Settings Check magento 2 error

Did you try the suggestion by @Dmitry_Fedyuk? You might be changing in a php.ini file that is not loaded by the server. 

Re: PHP Settings Check magento 2 error

I have the same problem. I have changed the all php.ini file but nothing happened. Please help.

Re: PHP Settings Check magento 2 error

Hi, i've just tried (without finding this place) to chane the value - my right place is at ispconfig website config own php-settings

 

But i've noticed, the problem isn't in the settings but the checker - somewhereSmiley Tongue

 

at <site>/var/.setup_cronjob_status part of it:

        "php_settings_verified": {
            "responseType": "success",
            "data": {
                "always_populate_raw_post_data": {
                    "message": "Your PHP Version is 5.6.14-0+deb8u1, but always_populate_raw_post_data = -1.\n \t        $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0.\n \t        This will stop the installer from running.\n\t        Please open your php.ini file and set always_populate_raw_post_data to -1.\n \t        If you need more help please call your hosting provider.",
                    "helpUrl": "http://php.net/manual/en/ini.core.php#ini.always-populate-settings-data",
                    "error": false
                }
            }
        }

it IS in -1 state, but checker says error ... so, i think its a bug ... please correct me if need Smiley Happy