cancel
Showing results for 
Search instead for 
Did you mean: 

PHP5.6: yum install:Skipped (dependency problems):php56w-devel.x86_64 php56w-gd.x86_64

PHP5.6: yum install:Skipped (dependency problems):php56w-devel.x86_64 php56w-gd.x86_64

 

yum install -y php56w php56w-opcache php56w-xml php56w-mcrypt php56w-gd php56w-devel php56w-mysql php56w-intl php56w-mbstring php56w-bcmath --skip-broken

 

Installed:
  php56w.x86_64 0:5.6.15-1.w6            php56w-bcmath.x86_64 0:5.6.15-1.w6     
  php56w-intl.x86_64 0:5.6.15-1.w6       php56w-mbstring.x86_64 0:5.6.15-1.w6   
  php56w-mcrypt.x86_64 0:5.6.15-1.w6     php56w-mysql.x86_64 0:5.6.15-1.w6      
  php56w-opcache.x86_64 0:5.6.15-1.w6    php56w-xml.x86_64 0:5.6.15-1.w6        

Dependency Installed:
  libmcrypt.x86_64 0:2.5.8-9.el6           php56w-cli.x86_64 0:5.6.15-1.w6      
  php56w-common.x86_64 0:5.6.15-1.w6       php56w-pdo.x86_64 0:5.6.15-1.w6      

Skipped (dependency problems):
  php56w-devel.x86_64 0:5.6.15-1.w6        php56w-gd.x86_64 0:5.6.15-1.w6

Complete!

 

[root@localhost ~]# yum install php56w-devel.x86_64 php56w-gd.x86_64
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager

Resolving Dependencies
--> Running transaction check
---> Package php56w-devel.x86_64 0:5.6.15-1.w6 will be installed
--> Processing Dependency: pcre-devel(x86-64) for package: php56w-devel-5.6.15-1.w6.x86_64
--> Processing Dependency: automake for package: php56w-devel-5.6.15-1.w6.x86_64
--> Processing Dependency: autoconf for package: php56w-devel-5.6.15-1.w6.x86_64
---> Package php56w-gd.x86_64 0:5.6.15-1.w6 will be installed
--> Processing Dependency: libt1.so.5()(64bit) for package: php56w-gd-5.6.15-1.w6.x86_64
--> Processing Dependency: libXpm.so.4()(64bit) for package: php56w-gd-5.6.15-1.w6.x86_64
--> Finished Dependency Resolution
Error: Package: php56w-devel-5.6.15-1.w6.x86_64 (webtatic)
           Requires: autoconf
Error: Package: php56w-devel-5.6.15-1.w6.x86_64 (webtatic)
           Requires: pcre-devel(x86-64)
Error: Package: php56w-gd-5.6.15-1.w6.x86_64 (webtatic)
           Requires: libXpm.so.4()(64bit)
Error: Package: php56w-devel-5.6.15-1.w6.x86_64 (webtatic)
           Requires: automake
Error: Package: php56w-gd-5.6.15-1.w6.x86_64 (webtatic)
           Requires: libt1.so.5()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]#

 

 

 

 

 

 

 

2 REPLIES

Re: PHP5.6: yum install:Skipped (dependency problems):php56w-devel.x86_64 php56w-gd.x86_64

you have to install missing packages. do you have base CentOS repo installed??

------------
MagenX - Magento and Server optimization

Re: PHP5.6: yum install:Skipped (dependency problems):php56w-devel.x86_64 php56w-gd.x86_64

Thanks very much for the reply!

 

Fixed.