cancel
Showing results for 
Search instead for 
Did you mean: 

Problems upgrading PHP on CENTOS7

Problems upgrading PHP on CENTOS7

hello all,

 

i'm struggling to upgrade PHP according to the guide : 

 

http://devdocs.magento.com/guides/v2.0/install-gde/prereq/php-centos.html

 

 

[root@hosting01 admin]# yum -y update
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
 * base: mirror.nl.leaseweb.net
 * epel: nl.mirror.babylon.network
 * extras: mirror.nl.leaseweb.net
 * ius: mirror.amsiohosting.net
 * remi-safe: nl.mirror.babylon.network
 * updates: mirror.nl.leaseweb.net
 * webtatic: uk.repo.webtatic.com
No packages marked for update
[root@hosting01 admin]# yum -y update
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
 * base: mirror.nl.leaseweb.net
 * epel: nl.mirror.babylon.network
 * extras: mirror.nl.leaseweb.net
 * ius: mirror.amsiohosting.net
 * remi-safe: nl.mirror.babylon.network
 * updates: mirror.nl.leaseweb.net
 * webtatic: uk.repo.webtatic.com
No packages marked for update
[root@hosting01 admin]# yum -y install php70u php70u-pdo php70u-mysqlnd php70u-opcache php70u-xml php70u-mcrypt php70u-gd php70u-devel php70u-mysql php70u-intl php70u-mbstring php70u-bcmath php70u-json php70u-iconv
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
 * base: mirror.nl.leaseweb.net
 * epel: nl.mirror.babylon.network
 * extras: mirror.nl.leaseweb.net
 * ius: mirror.amsiohosting.net
 * remi-safe: nl.mirror.babylon.network
 * updates: mirror.nl.leaseweb.net
 * webtatic: uk.repo.webtatic.com
No package php70u available.
No package php70u-pdo available.
No package php70u-mysqlnd available.
No package php70u-opcache available.
No package php70u-xml available.
No package php70u-mcrypt available.
No package php70u-gd available.
No package php70u-devel available.
No package php70u-mysql available.
No package php70u-intl available.
No package php70u-mbstring available.
No package php70u-bcmath available.
No package php70u-json available.
No package php70u-iconv available.
Error: Nothing to do

 The reason for this upgrade is my php 5.5.32 on Centos 7.

 

The error that got it al started:

 

PHP Version Check

Your PHP version is . The required PHP version is .

2 REPLIES

Re: Problems upgrading PHP on CENTOS7

Download Epel repository details:

$ wget -q http://rpms.remirepo.net/enterprise/remi-release-7.rpm
$ wget -q https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Enable Epel repository:

$ sudo rpm -Uvh remi-release-7.rpm epel-release-latest-7.noarch.rpm
$ sudo yum-config-manager --enable remi-php70

Install PHP7 with:

$ sudo yum install php

If it's not working, try this:

$ sudo yum install php70

At the end, check your current php version in order to be sure that PHP7 is installed:

$ php --version
If this response was helpful to you, consider giving kudos to this post.
If this response solved your problem, click accept as solution to help others solve this issue

Re: Problems upgrading PHP on CENTOS7

Thanks a lot for your reply!

 

unfortunately that din't work out

 

* webtatic: uk.repo.webtatic.com
No package php available.
Error: Nothing to do
[root@hosting01 admin]#
[root@hosting01 admin]# At the
bash: At: command not found
[root@hosting01 admin]# sudo yum install php70
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
* base: centos.mirror.transip.nl
* epel: ftp.nluug.nl
* extras: centos.mirror.transip.nl
* ius: mirror.amsiohosting.net
* remi-php70: nl.mirror.babylon.network
* remi-safe: nl.mirror.babylon.network
* updates: centos.mirror.transip.nl
* webtatic: uk.repo.webtatic.com
No package php70 available.
Error: Nothing to do
[root@hosting01 admin]# ^C
[root@hosting01 admin]# cls
bash: cls: command not found
[root@hosting01 admin]# clear
[root@hosting01 admin]# wget -q http://rpms.remirepo.net/enterprise/remi-release-7.rpm
[root@hosting01 admin]# wget -q https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
[root@hosting01 admin]# sudo rpm -Uvh remi-release-7.rpm epel-release-latest-7.noarch.rpm
warning: remi-release-7.rpm: Header V4 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
Preparing... ################################# [100%]
package epel-release-7-9.noarch is already installed
package remi-release-7.3-1.el7.remi.noarch is already installed
[root@hosting01 admin]# sudo yum-config-manager --enable remi-php70
Loaded plugins: fastestmirror, langpacks
=============================== repo: remi-php70 ===============================
[remi-php70]
async = True
bandwidth = 0
base_persistdir = /var/lib/yum/repos/x86_64/7
baseurl =
cache = 0
cachedir = /var/cache/yum/x86_64/7/remi-php70
check_config_file_age = True
compare_providers_priority = 80
cost = 1000
deltarpm_metadata_percentage = 100
deltarpm_percentage =
enabled = True
enablegroups = True
exclude =
failovermethod = priority
ftp_disable_epsv = False
gpgcadir = /var/lib/yum/repos/x86_64/7/remi-php70/gpgcadir
gpgcakey =
gpgcheck = True
gpgdir = /var/lib/yum/repos/x86_64/7/remi-php70/gpgdir
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
hdrdir = /var/cache/yum/x86_64/7/remi-php70/headers
http_caching = all
includepkgs =
ip_resolve =
keepalive = True
keepcache = False
mddownloadpolicy = sqlite
mdpolicy = group:small
mediaid =
metadata_expire = 21600
metadata_expire_filter = read-onlySmiley Tongueresent
metalink =
minrate = 0
mirrorlist = http://rpms.remirepo.net/enterprise/7/php70/mirror
mirrorlist_expire = 86400
name = Remi's PHP 7.0 RPM repository for Enterprise Linux 7 - x86_64
old_base_cache_dir =
password =
persistdir = /var/lib/yum/repos/x86_64/7/remi-php70
pkgdir = /var/cache/yum/x86_64/7/remi-php70/packages
proxy = False
proxy_dict =
proxy_password =
proxy_username =
repo_gpgcheck = False
retries = 10
skip_if_unavailable = False
ssl_check_cert_permissions = True
sslcacert =
sslclientcert =
sslclientkey =
sslverify = True
throttle = 0
timeout = 30.0
ui_id = remi-php70
ui_repoid_vars = releasever,
basearch
username =

[root@hosting01 admin]# sudo yum install php
Loaded plugins: fastestmirror, langpacks, replace
remi-php70 | 2.9 kB 00:00
Loading mirror speeds from cached hostfile
* base: centos.mirror.transip.nl
* epel: ftp.nluug.nl
* extras: centos.mirror.transip.nl
* ius: mirror.amsiohosting.net
* remi-php70: nl.mirror.babylon.network
* remi-safe: nl.mirror.babylon.network
* updates: centos.mirror.transip.nl
* webtatic: uk.repo.webtatic.com
No package php available.
Error: Nothing to do
[root@hosting01 admin]# sudo yum install php70
Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
* base: centos.mirror.transip.nl
* epel: ftp.nluug.nl
* extras: centos.mirror.transip.nl
* ius: mirror.amsiohosting.net
* remi-php70: nl.mirror.babylon.network
* remi-safe: nl.mirror.babylon.network
* updates: centos.mirror.transip.nl
* webtatic: uk.repo.webtatic.com
No package php70 available.
Error: Nothing to do
[root@hosting01 admin]#