cancel
Showing results for 
Search instead for 
Did you mean: 

There has been an error processing your request

SOLVED

There has been an error processing your request

I successfully installed Magento 2.1.9 on my Linux shared hosting account. After that, I imported a database, which I used before for another installation of the same Magento 2.1.9. Immediately after doing so, an error message started displaying:

There has been an error processing your request
Exception printing is disabled by default for security reasons.
Error log record number: 186016207762

 

The following is what I have in the error log:

[Sun Dec 03 19:08:08.404169 2017] [access_compat:error] [pid 896462] [client 162.220.59.118:35904] AH01797: client denied by server configuration: /home/my_username/public_html/app/etc/config.php
[Sun Dec 03 18:58:04.608791 2017] [access_compat:error] [pid 836310] [client 162.220.59.118:35313] AH01797: client denied by server configuration: /home/my_username/public_html/app/etc/config.php
[Sun Dec 03 18:33:07.779867 2017] [access_compat:error] [pid 830039] [client 162.220.59.118:33931] AH01797: client denied by server configuration: /home/my_username/public_html/app/etc/config.php

I changed the file name from "pub/errors/local.xml.sample to "pub/errors/local.xml" and detailed error messages displayed in the browser:

Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory. 
The following modules are outdated:
Mageplaza_Core schema: current version - none, required version - 1.0.0
Mageplaza_Core data: current version - none, required version - 1.0.0
Mageplaza_LayeredNavigation schema: current version - none, required version - 2.0.0
Mageplaza_LayeredNavigation data: current version - none, required version - 2.0.0
Smartwave_Core schema: current version - none, required version - 2.0.0
Smartwave_Core data: current version - none, required version - 2.0.0
Smartwave_Filterproducts schema: current version - none, required version - 2.0.0
Smartwave_Filterproducts data: current version - none, required version - 2.0.0
Smartwave_Megamenu schema: current version - none, required version - 2.1.0
Smartwave_Megamenu data: current version - none, required version - 2.1.0
Smartwave_Porto schema: current version - none, required version - 2.7.1
Smartwave_Porto data: current version - none, required version - 2.7.1
Smartwave_Socialfeeds schema: current version - none, required version - 2.0.0
Smartwave_Socialfeeds data: current version - none, required version - 2.0.0

Error log record number: 778849911718

Does anyone know how to fix this issue? Thanks in advance.

2 REPLIES

Re: There has been an error processing your request

Hi @FlamyTech,

 

That message means that you'll need to execute this command on your Magento's root directory:

 

bin/magento setup:upgrade

After that you should be able to navigate the store.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: There has been an error processing your request

@Damian Culotta, a million thanks!