cancel
Showing results for 
Search instead for 
Did you mean: 

Ubuntu 18.04 server , Magento 2.x installation errors

Ubuntu 18.04 server , Magento 2.x installation errors

Hello,

I am getting readiness check errors while installing Magento 2.x

1.PHP version check error. 

PHP Version Check
Your PHP version is 7.2.7-1+ubuntu18.04.1+deb.sury.org+1. The required PHP version is ~7.0.13|~7.1.0. Hide detail

Download and install PHP from www.php.net using this PHP Documentation.

I have installed php 7 , 7.1 and 7.2 as shown below.

 ls /usr/bin/php* 
/usr/bin/php  /usr/bin/php7.1.0  /usr/bin/php7.2
uma@ubuntu:~$ which php
/usr/bin/php
uma@ubuntu:~$ php -version 
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/2070718/soap.so' (tried: /usr/lib/php/2070718/soap.so (/usr/lib/php/2070718/soap.so: cannot open shared object file: No such file or directory), /usr/lib/php/20170718//usr/lib/php/2070718/soap.so.so (/usr/lib/php/20170718//usr/lib/php/2070718/soap.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/2070718/bcmath' (tried: /usr/lib/php/2070718/bcmath (/usr/lib/php/2070718/bcmath: cannot open shared object file: No such file or directory), /usr/lib/php/20170718//usr/lib/php/2070718/bcmath.so (/usr/lib/php/20170718//usr/lib/php/2070718/bcmath.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/2070718/mcrypt' (tried: /usr/lib/php/2070718/mcrypt (/usr/lib/php/2070718/mcrypt: cannot open shared object file: No such file or directory), /usr/lib/php/20170718//usr/lib/php/2070718/mcrypt.so (/usr/lib/php/20170718//usr/lib/php/2070718/mcrypt.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 7.2.7-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Jun 22 2018 08:45:49) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.7-1+ubuntu18.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

Another error is regarding php extension mcrypt error while checking php extension.

Kindly suggest 

 

4 REPLIES

Re: Ubuntu 18.04 server , Magento 2.x installation errors

Hi @deepakdeshp,

 

I'm not sure about those extensions errors (you should check your stack installation again) but  also Magento doesn't support PHP 7.2 yet.

 

https://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

 

There is a project ongoing to have full support but isn't ready yet: https://github.com/magento-engcom/php-7.2-support

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Ubuntu 18.04 server , Magento 2.x installation errors

Thank you for your reply. I have php 7.0, 7.1 and 7.2 all installed on my
system , yet I am not able to install Magento

Thanks
Deepak

Re: Ubuntu 18.04 server , Magento 2.x installation errors

Hi @deepakdeshp,

 

I guess you will need (first) to solve your PHP problems.

Your screenshot shows some issues with PHP extensions on yoru server. Also, it shows you are using PHP 7.2

You should downgrade to PHP 7.1 and fix the PHP extensions issues before you can try to install Magento.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Ubuntu 18.04 server , Magento 2.x installation errors

Hello,
Thanks for the reply. I am aware of the problems and seeking help on how to
resolve them.
As indicated earlier, on Mint Linux 18 I have installed PHP 7.0,7.1 and 7.2
phpinfo in the browser indicates I am using php7.2. I also uninstalled
php7.2 with command *sudo apt purge php7.2 .*