cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install Magento Version 2.1.7 on PHP Version 7.1.6

Unable to install Magento Version 2.1.7 on PHP Version 7.1.6

Hello Team,

 

We are unable to install Magento Version 2.1.7 with PHP Version 7.1.6 and MySQL Version 5.6.36 on our CentOS 6.9 server. Showing below error:

================

Your PHP version is 7.1.6. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6.

================

 

Is there anyway so that we can install Magento Version 2.1.7 on PHP Version 7.1.6 ? Or we must have to downgrade the PHP version from 7.1.6 to PHP 7.0.6–7.0.x or 7.0.2

 

Any feedback should be appreciated.

 

Regards,

Tarak Nath

2 REPLIES

Re: Unable to install Magento Version 2.1.7 on PHP Version 7.1.6

@elagoontarak,

You must downgrade your php version from your latest 7.1 version.

You must have to install php 7.0.6–7.0.x or 7.0.2 because magento 2 doesn't support php 7.1 version yet.

You can find helpful information from blogs at here,Magento 2.1.x Technology Stack

 

Thanks.

 

If response was helpful to you,Consider giving kudos to the post.
If issue solved, click Accept as Solution.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Unable to install Magento Version 2.1.7 on PHP Version 7.1.6

@elagoontarak

For what it's worth, we were playing with running on 7.1 at one point, and were able to get it running by simply skipping the readiness check, thought it's probably not recommended.

 

magento-directory}/setup/src/Magento/Setup/Controller/Environment.php around Line 194

comment the following lines:

 //$setupCheck = $this->cronScriptReadinessCheck->checkSetup();
 //$updaterCheck = $this->cronScriptReadinessCheck->checkUpdater();

and add these two:

$setupCheck = ['success' => 1];
$updaterCheck = ['success' => 1];