cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install extension

Unable to install extension

magento-error.png

 

 

 

 

 

 

Hi, I'm trying to install this slider extension but having this message every time i run command.

 

I uploaded the slider files and run the command using Putty.

 

Any Idea what i did wrong?

 

https://github.com/SlavaYurthev/Slider-M2/wiki

 

7 REPLIES

Re: Unable to install extension

You have to upgrade your PHP version in the server. Magento 2 requires at least PHP 5.5.0 Version to support and so you cant run command because error directly shows that your php version is not compatible with Magento stack.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Unable to install extension

 

Hi, I used PHP 7.0 as you can see here http://ckdiy.com.sg/info.php

 

and Magento was installed successfully but why i cant run any command.

Re: Unable to install extension

Hi @ronnie315,

I cannot see the image you uploaded. Can you please copy paste the error you are getting.


--------
Give Kudos if it helped or Accept it as solution

Re: Unable to install extension

ckdiycom@ckdiy.com.sg [~]# cd public_html
ckdiycom@ckdiy.com.sg [~/public_html]# php bin/magento setup:upgrade
Magento supports PHP 5.5.0 or later. Please read http://devdocs.magento.com/guides/v1.0/install-gde/system-requirements.htmlckdiycom@ckdiy.com.sg [~/public_html]#

Re: Unable to install extension

Hi @ronnie315,

Sometimes the CLI version of PHP will be different from the web version. You need to check which version of PHP you are using for your command line. Are you using any XAMPP kind of tool?

try this to know what is your CLI version.

php -v 



--------
Give Kudos if it helped or Accept it as solution

Re: Unable to install extension

ea-php-cli Copyright 2017 cPanel, Inc.
PHP 5.4.45 (cli) (built: Feb  7 2018 02:51:33)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
ckdiycom@ckdiy.com.sg [~/public_html]# ^C
ckdiycom@ckdiy.com.sg [~/public_html]#

Re: Unable to install extension

Your CLI version of PHP is 5.4. Please upgrade it to PHP 7

You can follow below links on how to do that. Given links are only for reference please use it as you needed.

1. https://joshtronic.com/2017/03/26/upgrade-to-php-7x-on-ubunu-1404-lts/
2. http://www.techoism.com/upgrade-php-5-6-7-1-ubuntu/

 

--------
Give Kudos if it helped or Accept it as solution