cancel
Showing results for 
Search instead for 
Did you mean: 

Vendor autoload is not found. Please run 'composer install' under application root directory.

SOLVED

Vendor autoload is not found. Please run 'composer install' under application root directory.

I am trying to run the magento2 set up in local XAMPP - mac.

 

I have installed the composer using Terminal and magento2 : I am following this link, https://schogini.biz/magento/magento2-installation.html

 

While updating the composer using : composer update command, facing below error,

Composer\Downloader\TransportException]                                                                             
  The "https://packages.magento.com/packages.json" file could not be downloaded: php_network_getaddresses: getaddrinf  
  o failed: nodename nor servname provided, or not known                                                               
  failed to open stream: php_network_getaddresses: getaddrinfo failed: nodename nor servname provided, or not known  

Can anyone help me in this? 

 

 

4 REPLIES

Re: Vendor autoload is not found. Please run 'composer install' under application root directory.

Hi @Jaymin2WebD,


https://packages.magento.com/ to https://repo.magento.com/ ?

The first one was the old URL. You should remove that from your composer.json.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Vendor autoload is not found. Please run 'composer install' under application root directory.

Hello @Damian Culotta,

 

Thanks for the solutions. Yes, It works fine now. 

 

Thanks again.

 

Re: Vendor autoload is not found. Please run 'composer install' under application root directory.

Hello @Damian Culotta,

 

It works fine but after,

 

The readiness check tells me that the PHP extension intl. is missing.

 

I tried all the solutions provided here https://community.magento.com/t5/Installing-Magento-2/Missing-PHP-extension-intl/td-p/22260/highligh...

but none works for me.

 

- removed ; from php_intl.dll extension under php.ini file but same issue

- i can't find xdebug.max_nesting_level  in my php.ini file

- set always_populate_raw_post_data = -1, no luck

- one of the solutions here says, copy all icu*.dll PHP to Apache = any of the dlls related to this, I can't find here, even there is no bin directory under my apache directory. 

 

I have installed XAMPP 7.0.26-0 on my MAC OS X Yosemite 10.10.5

XAMPP using PHP Version 7.0.26 and Apache 2.0 Handler 

 

this is my php.ini path: /Applications/XAMPP/xamppfiles/etc

this is my Apache path : /Applications/XAMPP/xamppfiles/apache2

 

I have installed XAMPP again but same issue.

 

Please help me out. 

 

Thanks,

Re: Vendor autoload is not found. Please run 'composer install' under application root directory.

Hi @Jaymin2WebD,


I will need to investigate (I use Linux so I'm not the best option to try to find a problem on Mac).

I've saw some posts here into the forums about similar situations.

 

Maybe you can start checking another threads. I.e:

 

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"