cancel
Showing results for 
Search instead for 
Did you mean: 

Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Hi,

 

Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

getting the above error..

 

tried the "disable-tls":true  - same issue

restarted apache

 

there is no php version 5.6.5 on php.net, latest is 5.6.28 or 7, whch I can't install at this time

 

running openSUSE 13.2

 

any insights?

 

Thanks,

Johnny

4 REPLIES

Re: Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Hello,

 

Sorry, I misunderstood your question. Will edit/respond in a bit after checking this.

 

Edit:

You can find the download mirrors for PHP 5.6.5 at this url. Small versions are generally removed from the php.net downloads page in favor of major versions. With this in mind, I would suggest using the latest 7.x version as soon as you are able.

Leslie B.
Aspiration Hosting - Magento 1 & 2 Optimized Cloud Hosting
Problem solved? Click Accept as Solution!

Re: Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

You should use php7 in order to avoid further issues that might arise down the lane.

Here're few simple steps that you can perform to have php7 available on your environment 

 

apt-add-repository ppaSmiley Surprisedndrej/php
apt-get update
apt-get install php7.0

 

a2dismod php5

a2enmod php7.0

service apache2 restart

 

* use 'sudo' where needed. 

 

Do revert back if you run into trouble.

Re: Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

yes.. I have upgraded my servers to php 7.

 

thanks!

Re: Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Hi,

That error means you need to upgrade your php version equivalent to 5.6.5 or above to install magento 2. your current php version is 5.6.1

Thanks