Your PHP version is 5.6.1. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6
getting the above error..
tried the "disable-tls":true - same issue
there is no php version 5.6.5 on php.net, latest is 5.6.28 or 7, whch I can't install at this time
running openSUSE 13.2
Sorry, I misunderstood your question. Will edit/respond in a bit after checking this.
You can find the download mirrors for PHP 5.6.5 at this url. Small versions are generally removed from the php.net downloads page in favor of major versions. With this in mind, I would suggest using the latest 7.x version as soon as you are able.
You should use php7 in order to avoid further issues that might arise down the lane.
Here're few simple steps that you can perform to have php7 available on your environment
apt-get install php7.0
service apache2 restart
* use 'sudo' where needed.
Do revert back if you run into trouble.
yes.. I have upgraded my servers to php 7.
That error means you need to upgrade your php version equivalent to 5.6.5 or above to install magento 2. your current php version is 5.6.1