cancel
Showing results for 
Search instead for 
Did you mean: 

Your PHP version is 7.1.6. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Your PHP version is 7.1.6. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Hi,

 

I'm trying to install Magento 2 on my local XAMPP server and it gives me this errorscreenshot-2017-07-12-14-15-30.png

I know how to fix the issues with required PHP extensions. But I'm not sure if I need to downgrade my PHP version. Is there any other option for that? Or How can I downgrade without reinstalling XAMPP as I've number of other projects in there.

 

Thanks,

Rutul

3 REPLIES

Re: Your PHP version is 7.1.6. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

@rutulrocks Yes as you are trying to install Magento 2.1 you would need to downgrade your version of PHP as Magento 2.1 is only marked as compatible with these versions of php ~5.6.5|7.0.2|7.0.4|~7.0.6

 

Support for php 7.1 is coming in Magento 2.2 - see here.

Re: Your PHP version is 7.1.6. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

@FoomanThanks for your suggestion. Do have any idea how to downgrade PHP version in Xampp. I have a number of other projects also installed on the same localhost and I don't want them to get affected due to it.

 

Thanks,

Rutul

Re: Your PHP version is 7.1.6. The required PHP version is ~5.6.5|7.0.2|7.0.4|~7.0.6

Install xampp 2.5 in a separate directory (xampp2.5) which comes with php version 5.6.