cancel
Showing results for 
Search instead for 
Did you mean: 

always_populate_raw_post_data to -1

SOLVED

always_populate_raw_post_data to -1

HI, so im trying to make my way through the installation. Iv setup the VPS with plesk and updated php to 5.6

Now im getting this error 

PHP Settings Check

Server failed to respond. Please try again.

Need Help?

Your PHP Version is 5.6.18, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

 

 

Im looking for the php.ini file in the root and also iv looked in the htaccess but I cannot see "always_populate_raw_post_data"

in either of these. Am I looking in the wrong place?

 

thanks

Tarik

2 REPLIES

Re: always_populate_raw_post_data to -1

0 is the default value for the always_populate_raw_post_data option: http://php.net/manual/en/ini.core.php#ini.always-populate-raw-post-data

You should declare the option yourself with the custom -1 value.

Re: always_populate_raw_post_data to -1

thanks, all sorted now. Just a css file/folder permission problem now.