Showing results for 
Search instead for 
Did you mean: 

css/js files inaccessible/ showing error 404 after install

css/js files inaccessible/ showing error 404 after install

I have  succesfully installed Magento CE 2.1 on my Mac using MAMP

After I launch the page and admin I have no Css/Js or images from the sample data

I have read many troubleshooting messages and tried many different things.

In my browser the error links are all correct - 


After running:

/bin/magento setup:static-content:deploy


Successful: 858 files modified



New version of deployed files: 1467849323

all browser error files are present in the correct mamp folder




I have edited the di.xml file and replaced the Symlink to Copy





changed permissions to 755 and 644

find . -type f -exec chmod -c 644 {} \; && find . -type d -exec chmod -c 755 {} \;


I have also ensure that all of my AllowOverride settings are at All


These are my current versions running in my terminal

$ php -v

PHP 5.6.10 (cli) (built: Jul  6 2015 14:28:54)

Copyright (c) 1997-2015 The PHP Group

Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies

    with XCache v3.2.1, Copyright (c) 2005-2014, by mOo

    with XCache Optimizer v3.2.1, Copyright (c) 2005-2014, by mOo

    with XCache Cacher v3.2.1, Copyright (c) 2005-2014, by mOo

    with XCache Coverager v3.2.1, Copyright (c) 2005-2014, by mOo


$ httpd -v

Server version: Apache/2.2.29 (Unix)

Server built:   Jul  6 2015 13:11:49


$ httpd -M

Loaded Modules:

core_module (static)

so_module (static)

http_module (static)

mpm_prefork_module (static)

authn_file_module (shared)

authn_core_module (shared)

authz_host_module (shared)

authz_groupfile_module (shared)

authz_user_module (shared)

authz_core_module (shared)

access_compat_module (shared)

auth_basic_module (shared)

reqtimeout_module (shared)

filter_module (shared)

mime_module (shared)

log_config_module (shared)

env_module (shared)

headers_module (shared)

setenvif_module (shared)

version_module (shared)

proxy_module (shared)

proxy_connect_module (shared)

proxy_ftp_module (shared)

proxy_http_module (shared)

proxy_fcgi_module (shared)

proxy_scgi_module (shared)

proxy_wstunnel_module (shared)

proxy_ajp_module (shared)

proxy_balancer_module (shared)

proxy_express_module (shared)

slotmem_shm_module (shared)

lbmethod_byrequests_module (shared)

lbmethod_bytraffic_module (shared)

lbmethod_bybusyness_module (shared)

unixd_module (shared)

status_module (shared)

autoindex_module (shared)

negotiation_module (shared)

dir_module (shared)

alias_module (shared)

rewrite_module (shared)

hfs_apple_module (shared)

php5_module (shared)


$ mysql -v

Welcome to the MySQL monitor.  Commands end with ; or \g.

Your MySQL connection id is 68

Server version: 5.6.25 MySQL Community Server (GPL)


Most documentation I have read has said it will either be my apache rewrite module which appears to be correct


I am stuck now as I think I have tried all the available solutions.

Maybe I have made some small mistake along the way, but I have attempted to re-install a number of times and still had no luck.

Any information would be appreciated.

If i need to post any further information do not hesitate to ask Smiley Happy

Thanks in advance.