cancel
Showing results for 
Search instead for 
Did you mean: 

data-migration tool for Magento 2.1error

data-migration tool for Magento 2.1error

I tried to install data-migration tool for magento 2.1.0 from magento 1.9.2.4. After I typed in following commands:

(1) composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool

(2) composer require magento/data-migration-tool:2.1.0

 

I got following error message:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package magento/data-migration-tool 2.1.0 exists as magento/data-migration-tool[2.0.0, 2.0.2, 2.0.5, 2.0.7, 1.0.0-beta] but these are rejected by your constraint.


Installation failed, reverting ./composer.json to its original content.

 

Could somebody help me about it? thanks a lot.

4 REPLIES

Re: data-migration tool for Magento 2.1error

It doesn't exist for 2.1 yet, that's why you have the error

Re: data-migration tool for Magento 2.1error

maybe that tool you uses is not compatible with your version of Magento. check cart migration guide again

Re: data-migration tool for Magento 2.1error

In your case, I think you can clear all data and upgrade again with magento 2 upgrade steps. Errors in migration process are general. However, we try to avoid serious problems.

Re: data-migration tool for Magento 2.1error

Hello,

 

Can I get your current website URL for review ? once I review,  I will help you how to migrate properly.

 

Thank you

Madvin