cancel
Showing results for 
Search instead for 
Did you mean: 

help to solve this issue

help to solve this issue

I was installing Magento 2 on xxamp, extracted all the files into htdocs. When I go to localhost/magento I get a fatal error:

 

Fatal error: Declaration of Zend\Mvc\Controller\PluginManager::get($name, ?array $options = NULL) must be compatible with Zend\ServiceManager\AbstractPluginManager::get($name, $options = Array, $usePeeringServiceManagers = true) in C:\xampp\htdocs\magento2\vendor\zendframework\zend-mvc\src\Controller\PluginManager.php on line 211

 Can someone tell what to do to fix this error

Tags (2)
5 REPLIES

Re: help to solve this issue

Hi @anni0007,

 

Which version of Magento and Xampp are you using? Which version of PHP?

I remember some case where the PHP version wasn't supported.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: help to solve this issue

I am using Xampp v3.2.2
php version Php/7.2.0
Magento version 2.2.2

Re: help to solve this issue

please someone help Asap!! to fix it

Re: help to solve this issue

Hi @anni0007,

 

Magento isn't compatible with PHP 7.2.0 yet.

You can check here the stack versions: http://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html#php

 

You should use another version of XAMPP, with the right version of PHP.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: help to solve this issue

But i installed previous in same xampp version same magento version it was installed easily also i was working with my dashboard.
But after when i added a catalog and then went at frontend of store then i clicked on option add to cart but nothing happened that's why i reinstalled magento than i encountered this problem.