cancel
Showing results for 
Search instead for 
Did you mean: 

magento 2 not using localphp.ini

magento 2 not using localphp.ini

hi

i've installed magento 2 using php verision PHP 7.0.30

 

the cron is set as follows

 

/usr/local/php70/bin/php-cli /home/hijabgem/public_html/bin/magento setup:cron:run >> /home/hijabgem/public_html/var/log/setup.cron.log     

 

memory limit is 1024m

 

by mistake before it was set to

/usr/local/php71/bin/php-cli /home/hijabgem/public_html/bin/magento setup:cron:run >> /home/hijabgem/public_html/var/log/setup.cron.log

 

memory limit read 512m

 

both of these values are regardless of whats written in the local php.ini

 

i think these memory limit values are coming from the global php.ini, which are server defaults

 

is there a way to make magento look at the local php ini instead

Tags (3)
9 REPLIES

Re: magento 2 not using localphp.ini

Hi @Umair

 

Well its totally depends on the server configuration !!

 

You have created local php.ini file that is correct , but if server declined to use that local php.ini file then there is no option at magento 2 application level to get the values from this local php.ini file.

 

so its totally depends on the server configuration , kindly request them or raise a ticket on them to allowed you either use of local php.ini  file or increase the memory in global php.ini file !!

 

 

if issue solved,Click Kudos & Accept as Solution

Re: magento 2 not using localphp.ini

they said that the system is using the local php.ini file, but for some reason magento is not, our cloud hosting plan allows us to make the neccessary changes we need to

 

http://www.hijabgem.com/info.php

 

but magento readiness check is reading 1024m

 

I'm just confused to why

 

by mistake before i set the cron to

/usr/local/php71/bin/php-cli /home/hijabgem/public_html/bin/magento setup:cron:run >> /home/hijabgem/public_html/var/log/setup.cron.log

 

the memory limit read 512m or omething

 

when i changed it to

/usr/local/php70/bin/php-cli /home/hijabgem/public_html/bin/magento setup:cron:run >> /home/hijabgem/public_html/var/log/setup.cron.log

 

it read 1024m after a minute or so

 

very confusing!

Re: magento 2 not using localphp.ini

Hi @Umair

 

okay i understand - i have seen your info.php - in local parameter memory_limit is still 756 MB

 

So you need to change its value to 2048M

 

Also can you please check what is there in your .htaccess file in root folder of magento 2 ?

 

in .htaccess file there should be a parameter like below : 

 

php_value memory_limit 768M
php_value max_execution_time 18000 

 

So please check and confirm what its value or change it from there and then check its showing or not !!

 

I have checked now value is updated to 2048M - is it works ?

if issue solved,Click Kudos & Accept as Solution

Re: magento 2 not using localphp.ini

after changing the .htacess value to 2048M

the local php value in info php has changed to 2048M and master value is 2048M

 

www.hijabgem.com/info.php

 

but magento is still reading 1024M

Re: magento 2 not using localphp.ini

Hi @Umair

 

How you identify magento 2 is reading 1024M ? - i am bit confused over here , if you changed memory and its showing 2048M in phpinfo - then magento 2 also takes the same memory !!

 

Moving ahead give you one more hint that might help you - in .htaccess file there should be a two option for php5 and php7 so check on both places you have changed or not !

if issue solved,Click Kudos & Accept as Solution

Re: magento 2 not using localphp.ini

now i can't access web setup wizard

 

i'm getting this headache again

 

Welcome to Magento Admin, your online store headquarters.
To use the Magento setup wizard sign into your Admin account and navigate to System => Tools => Web Setup Wizard

Re: magento 2 not using localphp.ini

i changed it for both php5 and php7

Re: magento 2 not using localphp.ini

Hi @Umair

 

okay , so what exactly shows when you click on web setup wizard ?

 

I think we have done all the possible ways at magento 2 side something is still missing at server side , you need to check at server level !!

 

Hope it helps !!

if issue solved,Click Kudos & Accept as Solution

Re: magento 2 not using localphp.ini

any recomendations on how to fix the new problem of not being able to acces web setup wizard

 

Welcome to Magento Admin, your online store headquarters.
To use the Magento setup wizard sign into your Admin account and navigate to System => Tools => Web Setup Wizard