cancel
Showing results for 
Search instead for 
Did you mean: 

magento2 community edition's successful installation but nowhere to do configuration

magento2 community edition's successful installation but nowhere to do configuration

I downloaded "Magento-CE-2.1.0-2016-06-23-02-28-19.tar.gz" and installed it in "www/magento2a/" on my virture private server successfully. 

 

Afterward,  there was the "Magento Admin Info" displayed on the screen as the following:

 

username:                                xxxxxx

email:                                        yyyyyy

password:                                 ********

your store address:                  http://65.60.54.133/magento2a/

magento admin address:       http://65.60.54.133/magento2a/admin_1cqjux/

......

 

Then I clicked the "magento admin address" with the above shown link and went to nowhere with an error message saying:

 

"Not Found

The requested URL/magento2a/admin_1cqjux/ was not found on this server.

---------------------------------------------------------------------------------------------------------

Apache 2.2.15(CentOS) Server at 65.60.54.133 Port 80"

 

Please help me out with this issue and thank you so much!

 

5 REPLIES

Re: magento2 community edition's successful installation but nowhere to do configuration

Hi @zhangzlili

 

Try following link Re: Unable to access /magento and /magento/admin , it should help you.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: magento2 community edition's successful installation but nowhere to do configuration

Hello Muk_t,

 

Thank you for the clue. And I have tried to modified the file "/etc/httpd/conf/httpd.conf" as instructed, but the problem is still the same.

 

My shared host runs Apache 2.2 and CentOS. And my magento installation base URL is /home/posnowz/magento2a/.

Do I need to modify the   "/etc/httpd/conf/httpd.conf" accordingly? 

 

And what is the variable "<value from Apache site>" 's value? Or can I just type this as it is?

Re: magento2 community edition's successful installation but nowhere to do configuration

Hello!

 

I have modified on my CentOS shared hosting machine the "/etc/httpd/conf/httpd.conf" as the following:

 

 

......

<Directory "/home/posnowz/www/magento2a/">

Options Indexes FollowSymLinks MultiViews

AllowOverride all

Order allow,deny

Allow from all

</Directory>

......

 

The "/home/posnowz/www/magento2a/" is my magento CE installation base URL.

 

Then I saved the file and typed the following:

 

# service httpd restart

 

Then, to configure my store,  I went to "65.60.54.133/magento2a" (my store front) & "65.60.54.133/admin_1cqjux/" (my store admin) 1st time successfully. But from 2nd time on, there were error message as the following:

 

"There has been an error processing your request

 

Exception printing is disabled by default for security reasons

Error log record number 1258847596017"

 

Please help me out with this.

 

Thank you so much!

Re: magento2 community edition's successful installation but nowhere to do configuration

Do you have IP tables setup that are blocking that port?  On the newer CentOS distros you have firewalld that needs to be configured for inbound traffic on specific ports.   If you're feeling brave you can do a service stop iptables and a service stop on firewalld which will open up the server to everything.  If you can then get to the website with those services disabled then you found your problem.

Re: magento2 community edition's successful installation but nowhere to do configuration

Actually on my CentOS shared hosting machine I typed into the file "/etc/httpd/conf/httpd.conf"  the following:

 

......

<Directory "/home/posnowz/www/magento2a/">

Options Indexes FollowSymLinks MultiViews

AllowOverride all***

Order allow,deny

Allow from all

</Directory>

......

 

The "/home/posnowz/www/magento2a/" is my magento CE installation base URL.

 

*** According to magento documentation, in the file  "/etc/httpd/conf/httpd.conf", it should be " ...... AllowOverride <value from Apache site> ......".  But I do not know exactly what this value is, so temporarily setting it "all" as a value. Perhaps, did this cause the error message?