cancel
Showing results for 
Search instead for 
Did you mean: 

when i run php --ini in ssh i get /usr/local/php56/lib

when i run php --ini in ssh i get /usr/local/php56/lib

when i run php --ini in ssh i get


Configuration File (php.ini) Path: /usr/local/php56/lib
Loaded Configuration File: /usr/local/php56/lib/php.ini
Scan for additional .ini files in: /usr/local/php56/etc
Additional .ini files parsed: /usr/local/php56/etc/extensions.ini,
/usr/local/php56/etc/limits.ini

 

does this mean magento is being corrupted because its trying to use php version 5.6

this is the info.php file

hijabgem.com/info.php

 

Even though Info.php says 7.0, and the local php.ini is set to php7.0

 

I've been having soo many issues installing it

Tags (2)
1 REPLY

Re: when i run php --ini in ssh i get /usr/local/php56/lib

Hi @Umair,

 

You're using two different versions of PHP (7.0 with Apache and 5.6 at CLI).

I don't knwo which Linux distro are you using but let me assume you are using Ubuntu and your 7.0 package of PHP is called: php7.0.

In that case you could execute this on your console:

 

sudo ln -sfn /usr/bin/php7.0 /etc/alternatives/php

That should do the trick. (But before execute this be sure about the name of the package).

Or maybe you can share your distro name and php package name to try to find the right command.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"