cancel
Showing results for 
Search instead for 
Did you mean: 

Install 2.1.0 - Your PHP version is . The required PHP version is .

SOLVED
Occasional Contributor

Install 2.1.0 - Your PHP version is . The required PHP version is .

Hi,

 

I'm trying to install 2.1.0 in a server with php 5.6.21 but it gives me the following error.

 

Thank you in advance

 

 

 

PHP Version Check

Your PHP version is . The required PHP version is . Hide detail

Download and install PHP from www.php.net using this PHP Documentation.

For additional assistance, contact your hosting provider.

PHP Settings Check *

Your PHP settings are correct.

 
Cannot determine required PHP extensions: Warning: is_dir(): open_basedir restriction in effect. File(/etc/pki/tls/certs) is not within the allowed path(s): (/home/sanikala/:/tmp:/var/tmp:/usr/local/lib/php/:/usr/local/php56/lib/php/) in /home/sanikala/domains/sanikala.com/public_html/vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php on line 914
PHP Extensions Check

missing PHP extensions. Hide detail

The best way to resolve this is to install the correct missing extensions. The exact fix depends on our server, your host, and other system variables.
Our PHP extension help can get you started.

For additional assistance, contact your hosting provider.

  • magento2
10 REPLIES
Super Contributor

Re: Install 2.1.0

you probably have multiple php versions running?

 

also open_basedir has some restrictions

------------
MagenX - Magento and Server optimization
Occasional Contributor

Re: Install 2.1.0

Hi

 

Thank you for replying. I run the <? phpinfo(); ?> code and the php info shows the php version 5.6.24

 

The site is hosted on a shared server how can I find out if they are using multiple version?

 

Thanks

Occasional Contributor

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

Hi,

 

It was SSL reason. In Magento 2.1.0 in default uses ssl. I'm not using ssl and the error arises. I just edit the config section of composer.json file in the root of magento and added the following line and every thing is OK. Thanks to tikosar

"disable-tls": true
New Contributor

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

Hello, specifically that part of the file you put esta Line? I do it because I still have problems:

 

"config": {
"use-include-path": true 
"disable-tls":true (LINE 50)
},

 

Cannot determine required PHP extensions: "/home/cophogar/public_html/composer.json" does not contain valid JSON Parse error on line 50: ... "disable-tls":true. "repositories" ----------------------^ Expected one of: 'EOF', '}', ',', ']'

 

Thanks

Senior Member

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

You forgot the "," at first line!

Occasional Contributor

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

Thanks for this solution!

New Contributor

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

Thank you for this solution and it works but when i start a extension install, i've the same problem.. Can anybody help me ? 

 

Greetings

 

 

Highlighted
Regular Visitor

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

Same here,

 

worked for first installation, but then stop working for enabling modules.

Occasional Visitor

Re: Install 2.1.0 - Your PHP version is . The required PHP version is .

Thanks! This is perfect!