cancel
Showing results for 
Search instead for 
Did you mean: 

Errore sito dopo installazione MatrixRate

SOLVED

Errore sito dopo installazione MatrixRate

Salve,

 

sto facendo delle prove su un sito gratuito per valutare il CMS (sito praticamente vuoto con qualche configurazione e un solo prodotto inserito).

Ho cercato di installare WebShopApps MatrixRate dal Magento Connect e, ad installazione avvenuta mi è crashato tutto rendendo impossibile l'accesso al backend.

Come posso fare?

Un problema simile mi è capitato durante l'installazione di un tema gratuito, preso sempre dallo store magento, in quel caso ho dovuto eliminare il file flag seguendo una guida su google ed è tornato tutto normale (tranne per il tema che comunque non ha installato)

 

Questo è il nome del sito: http://diablo2289.ilbello.com/errors/report.php?id=45188065&skin=default

 

Grazie mille per l'assistenza

3 REPLIES

Re: Errore sito dopo installazione MatrixRate

Ciao,

lo script seguente che crea la tabella shipping_matrixrate ti dà errore:

 

<magedir>/app/code/community/Webshopapps/Matrixrate/sql/matrixrate_setup/mysql4-install-2.0.2.php

 

L'errore è dato dal fatto che l'indice creato dalla seguente istruzione SQL supera il limite consentito:

 

UNIQUE KEY `dest_country` (`website_id`,`dest_country_id`,`dest_region_id`,`dest_city`,`dest_zip`,`dest_zip_to`,`condition_name`,`condition_from_value`,`condition_to_value`,`delivery_type`)

  

Probabilmente è solo un problema di configurazione di MySQL; se vuoi verificarlo prova a rimuovere quella riga e a rieseguire lo script (dovrebbe bastare un reload di pagina) però se hanno inserito quell'indice avevano i loro buoni motivi quindi fossi in te verificherei la configurazione MySQL.

 

Un saluto

Alessandro Ronchi -- https://github.com/aleron75

Re: Errore sito dopo installazione MatrixRate

Grazie mille per l'aiuto, ho provato a contattare il fornitore del server per verificare il blocco ma non ha mai risposto.

Pertanto ho preferito cancellare l'applicazione dalla cartella di root e mi si è riabilitato il backend.


Potrei farte un'altra domanda anche se in off topic? o devo aprirne un altro?


Grazie ancora

Re: Errore sito dopo installazione MatrixRate

>Potrei farte un'altra domanda anche se in off topic? o devo aprirne un altro?

 

meglio aprire thread apposito

 

un saluto

Alessandro Ronchi -- https://github.com/aleron75